Modify

Opened 5 years ago

Closed 5 years ago

#13269 closed defect (duplicate)

JOSM displays line which doesn't exist in the data

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core mappaint Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open attached file y.osm
  2. Run Validator, this should find 23 errors
  3. Open the error list
  4. Open the "unordered coastline" list
  5. Right click the first error (id 4.556.782), choose "Zoom to problem"
  6. Press - (Minus) three times to zoom out

What is the expected result?

A view of a part of the coastline

What happens instead?

The coastline is displayed, but also a blue line going to nowhere. This line disappears
when you try to zoom in on it.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-07-11 23:04:49 +0200 (Mon, 11 Jul 2016)
Build-Date:2016-07-12 01:31:48
Revision:10526
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10526 en) Windows 10 64-Bit
Memory Usage: 5711 MB / 5711 MB (4360 MB allocated, but free)
Java version: 1.8.0_102-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dsun.java2d.opengl=true]
Dataset consistency test: No problems found

Plugins:
- FastDraw (32639)
- apache-commons (32584)
- buildings_tools (32639)
- ejml (32639)
- geotools (32584)
- jts (32539)
- o5m (UNKNOWN)
- opendata (32584)
- pbf (32584)
- poly (32584)
- reverter (32584)
- utilsplugin2 (32584)

Last errors/warnings:
- W: Unable to delete file <josm.cache>\tiles\TMS.key
- W: Unable to delete file <josm.cache>\tiles\TMS.data
- W: Unable to delete file <josm.cache>\tiles\TMS_BLOCK.key
- W: Unable to delete file <josm.cache>\tiles\TMS_BLOCK.data
- W: Unable to delete file <josm.cache>\tiles\TMS_INDEX.key
- W: Unable to delete file <josm.cache>\tiles\TMS_INDEX.data
- W: Unable to delete file <josm.cache>\tiles\TMS_INDEX_v2.key
- W: Unable to delete file <josm.cache>\tiles\TMS_INDEX_v2.data

Attachments (2)

y.zip (4.6 MB) - added by anonymous 5 years ago.
screenshot.jpg (266.0 KB) - added by anonymous 5 years ago.

Change History (4)

Changed 5 years ago by anonymous

Attachment: y.zip added

Changed 5 years ago by anonymous

Attachment: screenshot.jpg added

comment:1 Changed 5 years ago by GerdP

Forgot to enter my email address, done now.

comment:2 Changed 5 years ago by Klumbumbus

Component: CoreCore mappaint
Resolution: duplicate
Status: newclosed

Closed as duplicate of #8429.
This is a rendering artefact of line casing. Known but unresolved.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.