Modify

Opened 7 years ago

Closed 3 years ago

#8429 closed defect (fixed)

MapCSS rendering issue when using casing

Reported by: imagic Owned by: team
Priority: normal Milestone: 16.08
Component: Core mappaint Version: latest
Keywords: Cc: michael2402, GerdP

Description

I encountered an obviously very rare rendering issue when testing a complex mapcss style. In the first attached picture the issue is visible. In the second picture it disappeared after moving the visible area just a little.

I reduced the mapcss style to a minimum and created a .osm file (both attached). In the third attached picture:

  • If you move node A or B just a little the issue will not occur.
  • If node A is visible the issue does not occur.
  • If you move the visible area in such a way that node A disappears to the right out of the visible area the issue does not occur.
  • If you move the visible area in such a way that node A is outside of the visible area to the top the issue _does_ occur.
  • If you move the visible area so that even node B is outside the visible area to the top the issue does not occur.
  • If you move the visible area so that node B is outside the visible area to the right the issue does not occur.

This description is not 100%: if you move the nodes just a little it might happen under some other circumstances or not at all. With the attached .osm and style it is always reproducible at various zoom levels. The relevant attribute that causes the issue seems to be left-casing-width resp. right-casing-width.

The issue was first discovered with JOSM 5705 and verified with 5716.

Attachments (7)

Rendering Issue 1.jpeg (184.2 KB) - added by imagic 7 years ago.
Issue visible with complex style active
Rendering Issue 2.jpeg (185.2 KB) - added by imagic 7 years ago.
Issue not visible after moving a little
Rendering Issue 10.jpeg (147.5 KB) - added by imagic 7 years ago.
Image with reduced style, issue not visible
Rendering Issue.osm (1.3 KB) - added by imagic 7 years ago.
Example .osm file
Rendering Issue.mapcss (119 bytes) - added by imagic 7 years ago.
Minimalistic style that reproduces the issue with the example .osm file
Rendering issue with style.jpeg (316.1 KB) - added by imagic 7 years ago.
Rendering issue visible; obviously not the casing
Rendering_issue_20140205.png (32.8 KB) - added by imagic 6 years ago.
repeat-image rotated

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by imagic

Attachment: Rendering Issue 1.jpeg added

Issue visible with complex style active

Changed 7 years ago by imagic

Attachment: Rendering Issue 2.jpeg added

Issue not visible after moving a little

Changed 7 years ago by imagic

Attachment: Rendering Issue 10.jpeg added

Image with reduced style, issue not visible

Changed 7 years ago by imagic

Attachment: Rendering Issue.osm added

Example .osm file

Changed 7 years ago by imagic

Attachment: Rendering Issue.mapcss added

Minimalistic style that reproduces the issue with the example .osm file

Changed 7 years ago by imagic

Rendering issue visible; obviously not the casing

comment:1 Changed 7 years ago by imagic

Detected some new issue at this way: http://www.openstreetmap.org/browse/way/5899554
Up to now I thought that only the casing is affected but in the screenshot "Rendering issue with style" the casing alone can't be the problem.

The screenshot is from JOSM 5716 with version 1.0-25_2013-03-06 of the style "Lane and Road Attributes". What we see there is that the background of a whole lane is drawn too far; also the linecap is drawn round although all lanes usually specify "none". Furthermore we see some road markings in the middle of a lane (or not: see below) - they are rendered using casing with dashes. Interesting there is that the length of the dashes is not correct for the current zoom level. If you take a look at the length of the road marking dashes on the correctly rendered part you see that the dashes are longer.
There is another possibility for the road markings "in the middle of a lane". The width of those lanes double for each zoom level. So maybe this is not a single lane but two lanes and the road markings are at the correct place and also with the correct dashes. This would mean that we see here something rendered for a different zoom level than we actually have.

When I deleted the tag width:lanes:forward=3.25|3 the problem changes. Instead of a too long lane I see now a too long sidewalk. Sidewalks are rendered as casings.

Also worth mentioning is the fact the the incorrect rendered part is also rendered red when selecting the way.

Finally one note: I haven't uploaded my changes yet so you wont see the tags (and the problem) for maybe one or two hours.

Changed 6 years ago by imagic

repeat-image rotated

comment:2 Changed 6 years ago by imagic

I just added another screenshot, which might or might not be related: Rendering_issue_20140205.png
Again I used the style "Lane and Road Attributes", now in version 2.2. In the screenshot we see that the background of a lane is drawn too far and we also see the repeat-image drawn twice: correct and 180° rotated.

comment:3 Changed 3 years ago by Klumbumbus

Ticket #13269 has been marked as a duplicate of this ticket.

comment:4 Changed 3 years ago by Klumbumbus

Cc: michael2402 GerdP added

It seems that in the course of #13306, #13375 and #13385 (maybe others too) this bug was completely fixed :)
Different rendering artefacts, which I can reproduce with current tested version r10786 I cannot reproduce with r10888.

Also casings and oneway arrows now always stay in place relative to the way line when moving the mapview, which is also a great improvement.

comment:5 Changed 3 years ago by Klumbumbus

Milestone: 16.08
Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.