Modify

Opened 7 years ago

Closed 7 years ago

#8428 closed defect (fixed)

Buttons in side windows missing

Reported by: Bernhard Hiller <bhil@…> Owned by: Don-vip
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc: Don-vip

Description

After the update to version 5697, I noticed that no buttons are available in the side windows for adding/editing/deleting tags or starting the validation of selected data. This is shown in a screenshot (attached).
However, when I start JOSM as an Administrator, the buttons are available.
I do not think that it is good practise to use the administrator account for everything, or for running "normal" programs which ought not need administrative access to the system. Please add the buttons back for normal users - I will meanwhile return to version 5608.

System: Windows 7 64bit; Java 1.6.0_27 (josm.exe and java.exe are 32bit processes)

Attachments (2)

JOSM5697.png (27.1 KB) - added by bhil@… 7 years ago.
screen shot
preferences.xml (45.6 KB) - added by bhil@… 7 years ago.
JOSM Preferences

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by bhil@…

Attachment: JOSM5697.png added

screen shot

comment:1 Changed 7 years ago by akks

Cc: Don-vip added

Administrator just have different settings directory, nothing more.

Please try older snapshot http://josm.openstreetmap.de/download/josm-snapshot-5683.jar
and tell if the bug is gone (or attach %appdata%/preferences.xml, removing the password from it!)

Try also setting advanced parameter dialog.dynamic.buttons to true.

It seems the revision r5689 is causing this problem (I can not reproduce it myself).

Last edited 7 years ago by akks (previous) (diff)

comment:2 Changed 7 years ago by Don-vip

Maybe buttons are set as "always hidden" but they were appearing because of the bug resolved in r5689 (#8143)
Please try with a clean profile, it should be OK.

comment:3 Changed 7 years ago by Bernhard Hiller <bhil@…>

With version 5683, the buttons are visible. With 5689, they are not.
Setting were checked.
It does not matter how the button behavior is set - they do not appear when hovering with the mouse over the area where they are expected to be.

comment:4 Changed 7 years ago by Don-vip

Can you please attach your preferences file ? Thanks.

Changed 7 years ago by bhil@…

Attachment: preferences.xml added

JOSM Preferences

comment:5 Changed 7 years ago by akks

I confirm, bug is reproduced with these preferences. Even changing dynamic buttons=true does not help, only enabling buttons manually.

comment:6 Changed 7 years ago by Don-vip

Owner: changed from team to Don-vip

comment:7 Changed 7 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 5718/josm:

fix #8428 - Always show buttons for legacy setting .buttonhiding=false + constructors javadoc

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.