Modify

Opened 4 years ago

Closed 14 months ago

Last modified 14 months ago

#12627 closed enhancement (fixed)

Should not display multiple warnings when the affected elements are the same

Reported by: naoliv Owned by: team
Priority: normal Milestone: 19.05
Component: Core validator Version:
Keywords: mapcss Cc: simon04, Klumbumbus

Description

Validated the attached file and see how we get two Overlapping Identical Natural Areas warnings.
Note that the 2 warnings are about the same elements.

Could JOSM group such warnings and display only one message when the affected objects are the same? (regardless if the message is about "object A and B" or "object B and A", since the order doesn't matter here)

JOSM:

Build-Date:2016-03-14 20:32:04
Revision:9993
Is-Local-Build:true

Identification: JOSM/1.5 (9993 SVN en) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 765 MB / 3641 MB (342 MB allocated, but free)
Java version: 1.8.0_72-internal-b15, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Attachments (1)

overlapping.osm (1.2 KB) - added by naoliv 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by naoliv

Attachment: overlapping.osm added

comment:1 Changed 4 years ago by Don-vip

Cc: simon04 added
Keywords: mapcss added

The warning is thrown from geometry.mapcss:

/* see ticket #9556 */
area:closed:areaStyle[tag("natural") = parent_tag("natural")]  area:closed:areaStyle[natural] {
  throwWarning: tr("Overlapping Identical Natural Areas");
}

any idea how to solve that?

comment:2 Changed 4 years ago by Klumbumbus

Cc: Klumbumbus added

comment:3 Changed 3 years ago by Don-vip

Ticket #9821 has been marked as a duplicate of this ticket.

comment:4 Changed 3 years ago by Don-vip

In 11493/josm:

see #12627, see #14289 - add non regression unit tests

comment:5 Changed 14 months ago by GerdP

Resolution: fixed
Status: newclosed

In 15064/josm:

fix #12627,#14287,#14289,#17695

  • let CrossingFinder and ContainsFinder find all objects instead of stopping at first match
  • if objects are selected, make sure that ContainsFinder is called for enclosing objects which are not in the selection
  • enable corresponding unit tests

Draw back: MapCSSTagChecker is a bit slower.

comment:6 Changed 14 months ago by Klumbumbus

Milestone: 19.05

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.