Modify

Opened 3 years ago

Closed 3 years ago

#12583 closed defect (fixed)

Update Data dialog did not show progress (Regression)

Reported by: mdk Owned by: team
Priority: normal Milestone: 16.06
Component: Core Version: latest
Keywords: template_report regression Cc: simon04

Description

What steps will reproduce the problem?

  1. Download some (larger) areas
  2. Use "Update data" (CTRL-U)

What is the expected result?

The dialog

The progress of a single download is shown (kB in the first line).
The progress of the downloads is shown (second line)

What happens instead?

Only the size of the first download is shown. Afterwords the dialog is not longer updated (size, counter and progressbar will not be changed until end). Only the map in the background changes and show the bounding box of the actual downloaded data.
This works fine some time ago, but I have no clue which version works :-(

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-02-28 14:07:49 +0100 (Sun, 28 Feb 2016)
Build-Date:2016-02-28 20:07:32
Revision:9900
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9900 en) Linux Ubuntu 15.10
Memory Usage: 435 MB / 876 MB (87 MB allocated, but free)
Java version: 1.8.0_66-internal-b17, Oracle Corporation, OpenJDK Server VM
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/michael/.josm-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- ColumbusCSV (31772)
- FastDraw (31895)
- HouseNumberTaggingTool (31772)
- Mapillary (32040)
- OpeningHoursEditor (31772)
- RoadSigns (31895)
- SimplifyArea (31895)
- apache-commons (31895)
- apache-http (31895)
- buildings_tools (31895)
- contourmerge (1014)
- imagery-xml-bounds (31772)
- imagery_offset_db (32046)
- pbf (31772)
- poly (31772)
- public_transport (31895)
- reltoolbox (31895)
- reverter (32005)
- terracer (31895)
- turnrestrictions (31895)
- utilsplugin2 (32018)

Attachments (1)

Update data dialog.png (10.9 KB) - added by mdk 3 years ago.

Download all attachments as: .zip

Change History (14)

Changed 3 years ago by mdk

Attachment: Update data dialog.png added

comment:1 Changed 3 years ago by Don-vip

Keywords: regression added

comment:2 Changed 3 years ago by Don-vip

Milestone: 16.03
Priority: minornormal

comment:3 Changed 3 years ago by Don-vip

Ticket #12621 has been marked as a duplicate of this ticket.

comment:4 Changed 3 years ago by Don-vip

Milestone: 16.0316.04

Milestone renamed

comment:5 Changed 3 years ago by Don-vip

r9524 works, r9535 doesn't

comment:6 Changed 3 years ago by Don-vip

Cc: simon04 added

Looks like a regression of r9529

comment:7 Changed 3 years ago by Don-vip

@simon: do you know how to fix this?

comment:8 Changed 3 years ago by Don-vip

Ticket #12784 has been marked as a duplicate of this ticket.

comment:9 Changed 3 years ago by bastiK

Resolution: fixed
Status: newclosed

In 10160/josm:

partial revert of [9529] (fixes #12583)

possibly breaking tests

comment:10 Changed 3 years ago by bastiK

Milestone: 16.0416.05
Resolution: fixed
Status: closedreopened

org.openstreetmap.josm.tools.HttpClientTest.testPost and org.openstreetmap.josm.tools.HttpClientTest.testPostZero are failing (as anticipated).

The question was to have a bug in the program (r9529 - r10159) or in the tests (before r9529 and after r10159). Fixing both at the same time is more difficult and is preferably done by someone who already knows the code (Simon ;-) ).

comment:11 Changed 3 years ago by Don-vip

these tests are the only ones failing. Simon, can you please look into it?

comment:12 Changed 3 years ago by Don-vip

Milestone: 16.0516.06

comment:13 Changed 3 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 10302/josm:

fix #12583 - fix unit tests by adding a new mode to HttpClient. Don't know if it's the best way to do it...

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.