Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 months ago

#12400 closed defect (fixed)

reverter plugin broken

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin reverter Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. try to revert a changeset
  2. try to upload

What is the expected result?

changeset gets reverted

What happens instead?

unhandled exception

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-18 01:46:48 +0100 (Mon, 18 Jan 2016)
Build-Date:2016-01-18 02:34:44
Revision:9524
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9524 en) Mac OS X 10.11.2
Memory Usage: 588 MB / 1820 MB (131 MB allocated, but free)
Java version: 1.8.0_66-b17, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dsun.java2d.opengl=true]
Dataset consistency test: No problems found

Plugins:
- TombPlugin (46)
- alignways (31895)
- apache-commons (31895)
- apache-http (31895)
- buildings_tools (31895)
- geochat (31895)
- imagery_offset_db (31895)
- print (31895)
- proj4j (31830)
- reltoolbox (31895)
- reverter (31926)
- undelete (31895)
- utilsplugin2 (31895)

Last errors/warnings:
- E: java.lang.UnsupportedOperationException

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by simon04

In 9530/josm:

see #12400 - reverter plugin broken - fix UnsupportedOperationException

Regression of r9514.

comment:2 Changed 4 years ago by simon04

The ReverterUploadHook still needs to be adapted to r9514

comment:3 Changed 4 years ago by simon04

Component: CorePlugin reverter
Resolution: fixed
Status: newclosed

Fixed in [o32005:32006].

comment:4 Changed 5 months ago by GerdP

This change also removed the usage of field ReverterUploadHook.pluginString, was that intended?

comment:5 Changed 4 months ago by GerdP

Hm, no comments from anybody so I assume the change was not intended. I'll revert it on friday with the patch posted for #17540.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.