Modify

Opened 19 months ago

Closed 18 months ago

Last modified 16 months ago

#12035 closed enhancement (fixed)

Add office=* items to internal presets

Reported by: Don-vip Owned by: team
Priority: normal Milestone: 15.11
Component: Internal preset Version:
Keywords: office license Cc: bastiK

Description (last modified by Don-vip)

office is widely used (150k occurences) but yet missing from the internal presets, although some values are rendered by the default map style.

We have examples in Presets/NewTags.

Some ideas for icons:

Tag 16px 24px
`office=accountant` https://cdn4.iconfinder.com/data/icons/24x24-free-application-icons/24/Accounting.png https://cdn4.iconfinder.com/data/icons/24x24-free-application-icons/24/Accounting.png
`office=advertising_agency` https://cdn3.iconfinder.com/data/icons/fugue/icon/megaphone.png https://cdn3.iconfinder.com/data/icons/fugue/bonus/icons-24/megaphone.png
`office=employment_agency` https://cdn4.iconfinder.com/data/icons/cologne/16x16/free-for-job.png https://cdn4.iconfinder.com/data/icons/cologne/32x32/free-for-job.png
`office=government` https://cdn4.iconfinder.com/data/icons/Project_Icons___Version_1_1_9_by_bogo_d/PNG/Library.png https://cdn4.iconfinder.com/data/icons/Project_Icons___Version_1_1_9_by_bogo_d/PNG/Library.png
`office=insurance` https://cdn4.iconfinder.com/data/icons/24x24-free-pixel-icons/24/Shield.png https://cdn4.iconfinder.com/data/icons/24x24-free-pixel-icons/24/Shield.png
`office=it` https://cdn2.iconfinder.com/data/icons/gnomeicontheme/16x16/devices/gnome-dev-computer.png https://cdn2.iconfinder.com/data/icons/gnomeicontheme/24x24/devices/gnome-dev-computer.png
`office=newspaper` https://cdn2.iconfinder.com/data/icons/fugue/icon/newspaper.png https://cdn2.iconfinder.com/data/icons/fugue/bonus/icons-24/newspaper.png
`office=research` https://cdn2.iconfinder.com/data/icons/gnomeicontheme/16x16/categories/applications-science.png https://cdn2.iconfinder.com/data/icons/gnomeicontheme/24x24/categories/applications-science.png

Attachments (0)

Change History (24)

comment:1 Changed 18 months ago by Klumbumbus

Owner: changed from team to Klumbumbus
Status: newassigned

comment:2 Changed 18 months ago by Klumbumbus

In 9011/josm:

see #12035 - add office=* items to internal preset and mappaint style

comment:3 Changed 18 months ago by Klumbumbus

This is with generic icon for now.

I added all values from the table at Key:office except:

I did not add the following values because they are duplicates: realtor and real_estate_agent (duplicate of estate_agent), tax (duplicate of government), travel_agent (duplicate of shop=travel_agency)

I did not add the following values because of low usage numbers: forestry (146) , guide (28), private_investigator (6), quango (148), register (134), water_utility (65)

(numbers from taginfo from today)

comment:4 Changed 18 months ago by aceman

Thanks!

comment:5 Changed 18 months ago by aceman

May there be strings clashes here with existing strings which cause problems for translators. I'm thinking e.g. "administrative" (boundary), telecommunication (tower:type), religion (religion key). Is a context needed?

comment:6 in reply to:  5 Changed 18 months ago by Klumbumbus

Replying to aceman:

Is a context needed?

It is already in there. name_context="office"

comment:7 Changed 18 months ago by aceman

Ah yes, sorry.

comment:8 Changed 18 months ago by Klumbumbus

Owner: changed from Klumbumbus to team
Status: assignednew

If individual icons are wanted then I would need some help, because finding/editing a good icon takes a lot of time sometimes. The icons in Presets/NewTags are problematic, because the source and license is unclear and some are german specific.

Please see icon guidelines => DevelopersGuide/DefaultPresets

comment:10 Changed 18 months ago by Don-vip

Description: modified (diff)

comment:11 Changed 18 months ago by Don-vip

Description: modified (diff)

comment:12 Changed 18 months ago by Don-vip

Description: modified (diff)

comment:13 Changed 18 months ago by Don-vip

Description: modified (diff)

comment:14 Changed 18 months ago by Don-vip

Description: modified (diff)

comment:15 Changed 18 months ago by Don-vip

Description: modified (diff)

comment:16 Changed 18 months ago by Don-vip

Description: modified (diff)

comment:17 Changed 18 months ago by Don-vip

Description: modified (diff)

comment:18 Changed 18 months ago by Don-vip

Description: modified (diff)

comment:19 Changed 18 months ago by Klumbumbus

What about the license? I see that your linked icons are GPL or CC-BY. Do we need to add text to the about window. when using icons with such a license?

comment:20 Changed 18 months ago by Don-vip

Cc: bastiK added
Keywords: license added

I assume a mention in the last section of CONTRIBUTION file would be enough?

comment:21 Changed 18 months ago by Don-vip

Paul, is it OK to add CC-BY icons?

comment:22 Changed 18 months ago by Don-vip

Resolution: fixed
Status: newclosed

Let's continue the discussion to #12136.

comment:23 Changed 17 months ago by Don-vip

Ticket #12213 has been marked as a duplicate of this ticket.

comment:24 Changed 16 months ago by Klumbumbus

In 9681/josm:

see #12227 - add craft=* to preset and mappaint style, warn about craft=yes; fix office area style (see #12035); add traffic_sign to validator ignore list

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.