Modify

Opened 3 years ago

Closed 3 years ago

#12227 closed enhancement (fixed)

Add preset for craft=* tags

Reported by: anonymous Owned by: team
Priority: normal Milestone: 16.02
Component: Internal preset Version:
Keywords: craft Cc: gepeix

Attachments (1)

craftgroup.png (7.2 KB) - added by Klumbumbus 3 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 3 years ago by Don-vip

Keywords: craft added

comment:2 Changed 3 years ago by zermes

Here is a list of the most used. I'm making some icons for them. Just don't know which less used ones should be added to JOSM. Can anyone give a hint?

Value Count Wiki Page Notes
carpenter 3541 yes
shoemaker 2380 yes
photographer 2223 yes
metal_construction 2165 yes
electrician 2033 yes
brewery 1661 yes
tailor 1517 no Redirect to Tag:shop=tailor (4 640 uses) but in https://wiki.openstreetmap.org/wiki/Key:shop says to use craft=tailor
plumber 1464 yes
confectionery 1397 yes proposed to be merged with shop=confectionery
sawmill 1295 yes
gardener 1186 yes
winery 1103 yes
hvac 1089 yes
painter 1031 yes
stonemason 952 yes
handicraft 824 yes
dressmaker 780 yes proposed to be merged with craft=tailor
glaziery 733 yes proposed to be merged with shop=glaziery
pottery 725 yes
photographic_laboratory 699 yes
key_cutter 672 yes
caterer 644 yes
roofer 623 yes
beekeeper 584 yes
blacksmith 545 yes
locksmith 463 yes
yes 457 no - generic
window_construction 427 yes
upholsterer 399 yes
clockmaker 391 yes proposed to be merged with craft=watchmaker
tiler 387 yes
jeweller 382 yes
optician 345 yes
agricultural_engines 292 yes
distillery 286 yes
watchmaker 286 yes proposed to be merged with craft=clockmaker
joiner 226 yes
tinsmith 161 yes
plasterer 152 yes
bookbinder 146 yes
Last edited 3 years ago by zermes (previous) (diff)

comment:3 Changed 3 years ago by Klumbumbus

Ticket #10285 has been marked as a duplicate of this ticket.

comment:4 Changed 3 years ago by Klumbumbus

Cc: gepeix added

comment:5 Changed 3 years ago by Don-vip

Milestone: 16.02

comment:6 in reply to:  2 ; Changed 3 years ago by anonymous

Replying to zermes:

Redirect to Tag:shop=tailor

Yes zermes , but why in http://wiki.openstreetmap.org/wiki/Key:shop it's say "Use craft=tailor instead" ?? this description must be edited because we have already preset for shop=tailor and it's most used tag than craft=tailor.

comment:7 in reply to:  6 Changed 3 years ago by zermes

Replying to anonymous:

Replying to zermes:

Redirect to Tag:shop=tailor

Yes zermes , but why in http://wiki.openstreetmap.org/wiki/Key:shop it's say "Use craft=tailor instead" ?? this description must be edited because we have already preset for shop=tailor and it's most used tag than craft=tailor.

Oh, sorry. Didn't noted that. I was just describing the situation in OSM wiki. This is not "my proposal", it's just the more used tags shown in Taginfo. I've changed the notes column.

comment:8 Changed 3 years ago by anonymous

Hi users , can you look and treat my ticket ?

comment:9 in reply to:  8 Changed 3 years ago by Klumbumbus

Replying to anonymous:

Hi users , can you look and treat my ticket ?

We will soon. Please be patient. BTW, JOSM is usable even without Presets :)

comment:10 Changed 3 years ago by anonymous

Thank you for the comment, I think that you miss this ticket.

comment:11 Changed 3 years ago by Klumbumbus

Owner: changed from team to Klumbumbus

comment:12 Changed 3 years ago by Klumbumbus

In 9681/josm:

see #12227 - add craft=* to preset and mappaint style, warn about craft=yes; fix office area style (see #12035); add traffic_sign to validator ignore list

Changed 3 years ago by Klumbumbus

Attachment: craftgroup.png added

comment:13 Changed 3 years ago by Klumbumbus

I added the most used down to tiler except the ones which are unclear. For some we already have icons :) More icons are welcome :)


Last edited 3 years ago by Klumbumbus (previous) (diff)

comment:14 Changed 3 years ago by Klumbumbus

Owner: changed from Klumbumbus to team

comment:15 Changed 3 years ago by Klumbumbus

zermes, do you think you can provide some more icons in milestone/16.02?

comment:16 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

edit: comment removed (typo in ticketnumber)

Last edited 3 years ago by Klumbumbus (previous) (diff)

comment:17 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: closedreopened

comment:18 Changed 3 years ago by Klumbumbus

todo: stonemason has wrong icon (brick layer)

comment:19 Changed 3 years ago by Klumbumbus

In 9892/josm:

see #12227 - remove wrong stonemason icon; don't overwrite icons with no_icon.png icon (e.g. a node with entrance=yes and craft=caterer)

comment:20 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

fixed. for icons see #12575

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.