Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12028 closed defect (fixed)

Hide/disable way splitting dialog

Reported by: Klumbumbus Owned by: team
Priority: normal Milestone: 15.11
Component: Core Version:
Keywords: Cc: simon04

Description (last modified by Klumbumbus)

This is a follow-up of #10730. Especially ticket:10730#comment:14

The use of the preference key splitway.segment-selection-dialog is not yet perfect user experience to hide the split way dialog.

A more usefull practice could be (idea from http://forum.openstreetmap.org/viewtopic.php?pid=557913#p557913):

  • by default hide the dialog for all users (expert and non-expert)
  • to display the dialog all users can use a modifier (strg, alt, shift or whatever)

Attachments (0)

Change History (11)

comment:1 by Klumbumbus, 8 years ago

Description: modified (diff)

(deleted already implemented feature)

comment:2 by simon04, 8 years ago

Summary: Improvements to way splitting dialogHide/disable way splitting dialog

comment:3 by simon04, 8 years ago

Ticket #12031 has been marked as a duplicate of this ticket.

comment:4 by simon04, 8 years ago

Resolution: fixed
Status: newclosed

In 8978/josm:

fix #12028 - Hide/disable way splitting dialog

This drops preference key splitway.segment-selection-dialog and uses
"Do not show again" boxes instead.

comment:5 by Klumbumbus, 8 years ago

Resolution: fixed
Status: closedreopened

There is a problem with the width of the split window. It is even wider than my screen.

comment:6 by simon04, 8 years ago

Resolution: fixed
Status: reopenedclosed

In 8988/josm:

fix #12028 - Way splitting: fix dialog layout problem

comment:7 by DeeHants, 8 years ago

Are you still willing to add the hotkey/modifier to show the dialog as a one off rather than having to go into preferences, find and change the options, then split, ticking "don't show this again"?

comment:8 by simon04, 8 years ago

No. We virtually don't have any shortcuts left (DevelopersGuide/ShortcutsList) and I find the "don't show this again" more intuitive.

comment:9 by wernerschka, 8 years ago

Resolution: fixed
Status: closedreopened

And how to display this dialog again if somebody once selected "Do not show again"?
Wouldn't be a checkbox within JOSM's settings be a good idea to enable/disable this dialog?

comment:10 by wernerschka, 8 years ago

Resolution: fixed
Status: reopenedclosed

Sorry, I just found out, that there's still the possibility to enable the dialog again by switching the value of message.way.split.segment-selection-dialog to "true"

Maybe the Wiki could be updatet:
https://josm.openstreetmap.de/wiki/De%3AHelp/Action/SplitWay

in reply to:  10 comment:11 by Klumbumbus, 8 years ago

Replying to wernerschka:

Maybe the Wiki could be updatet:
https://josm.openstreetmap.de/wiki/De%3AHelp/Action/SplitWay

Done for English and German. You can do the docu also yourself.


See also #12290 for UI enhancement

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.