Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12031 closed defect (duplicate)

Way splitting: assign history automatically

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: way splitting Cc:

Description

What steps will reproduce the problem?

  1. select a way.
  2. press P to split the way.

What is the expected result?

The Splitting Tool shall not ask the user which way should keep the history, but answer this question automatically or let the user assign it to both way parts.

What happens instead?

Since version 8964 the user is asked which way should keep the history. The dialog only contains a mutual list of way parts, with no information about the history to keep. So answering this question is guessing. Secondly if I split the way I might want to keep the history for both parts, so the question is rather pointless. Thirdly this new dialog hinders the user in working quickly.

Please provide any additional information below. Attach a screenshot if possible.

I think this new behavior came in with revision 8886.

Revision: 8964
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: simon04
Last Changed Date: 2015-10-27 23:40:20 +0100 (Tue, 27 Oct 2015)
Build-Date: 2015-10-28 02:32:10
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8964

Identification: JOSM/1.5 (8964 de) Mac OS X 10.9.5
Memory Usage: 797 MB / 3641 MB (502 MB allocated, but free)
Java version: 1.8.0_60, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.security.policy=file:/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/lib/security/javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>/bin, -Djava.security.manager, -Djnlpx.origFilenameArg=/Users/svenclauner/Library/Application Support/Oracle/Java/Deployment/cache/6.0/56/1ee8cfb8-3fa0371d, -Djnlpx.remove=false, -Dsun.awt.warmup=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Dmacosx.jnlpx.dock.name=JOSM, -Dmacosx.jnlpx.dock.icon=/Users/svenclauner/Library/Application Support/Oracle/Java/Deployment/cache/6.0/16/47ee53d0-451327f0.icns, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp , -Djnlpx.jvm="/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java", -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAC1Eam5scC5hcHBsaWNhdGlvbi5ocmVmPWh0dHBzOi8vam9zbS5vcGVuc3RyZWV0bWFwLmRlL2Rvd25sb2FkL2pvc20uam5scCAA]
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (31694)
- FastDraw (31694)
- FixAddresses (31694)
- HouseNumberTaggingTool (31603)
- ShapeTools (1000)
- SimplifyArea (31694)
- buildings_tools (31694)
- continuosDownload (1446070193)
- download_along (31603)
- jts (31603)
- mapdust (31694)
- measurement (31694)
- terracer (31694)
- utilsplugin2 (31694)
- wikipedia (31694)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by simon04

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12028.

comment:2 Changed 4 years ago by simon04

The history to keep is the id of the way to split with all of its former versions (e.g., https://www.openstreetmap.org/way/31415926/history).

It is impossible for both split parts to keep the history. This is due to the design of the OSM API.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.