Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#11151 closed defect (fixed)

Not all buttons are shown in exit confirmation dialog

Reported by: holgermappt Owned by: team
Priority: normal Milestone: 15.10
Component: Core Version: latest
Keywords: template_report Cc: malenki

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Optional: Choose a language with long translations, e.g. German
  2. Create a data layer with unsaved changed
  3. Quit JOSM (Ctrl+q)
  4. Reduce the width of the Unsaved changes dialog window

What is the expected result?

All options are shown: Perform actions before exiting, Exit now, Cancel. Or an indication that there are more options, e.g. a scroll bar.

What happens instead?

Depending on the window size, one or two buttons are not displayed. There is no active button if no action is active and the window is small.

German with default window size, ''Cancel'' is missing.

German with wider window, now all buttons are shown.

English with reduced width, the only button is grayed out.

Please provide any additional information below. Attach a screenshot if possible.

Build-Date: 2015-02-22 17:57:05
Revision: 8098
Is-Local-Build: true

Identification: JOSM/1.5 (8098 SVN de) Linux openSUSE 13.2 (Harlequin) (x86_64)
Memory Usage: 481 MB / 7141 MB (342 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: java-1_7_0-openjdk:x86_64-1.7.0.75
Dataset consistency test: No problems found

Attachments (3)

unsaved_changes_german_default_size.png (19.1 KB) - added by holgermappt 5 years ago.
German with default window size, Cancel is missing.
unsaved_changes_german_increased_width.png (21.0 KB) - added by holgermappt 5 years ago.
German with wider window, now all buttons are shown.
unsaved_changes_english_reduced_width.png (14.4 KB) - added by holgermappt 5 years ago.
English with reduced width, the only button is grayed out.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by holgermappt

German with default window size, Cancel is missing.

Changed 5 years ago by holgermappt

German with wider window, now all buttons are shown.

Changed 5 years ago by holgermappt

English with reduced width, the only button is grayed out.

comment:1 Changed 5 years ago by holgermappt

There are more dialogs that have the same issue, e.g. the Open changesets window (File, Close open changesets).

comment:2 Changed 5 years ago by skyper

See also #7826. I have this problem also with several dialogs.

comment:3 Changed 5 years ago by Don-vip

Description: modified (diff)

comment:4 Changed 5 years ago by Don-vip

Ticket #11535 has been marked as a duplicate of this ticket.

comment:5 Changed 5 years ago by Don-vip

Cc: malenki added

comment:6 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 8912/josm:

fix #11151 - Not all buttons are shown in exit confirmation dialog

Use GridBagLayout to avoid disappearance of buttons.

comment:7 Changed 4 years ago by simon04

Milestone: 15.10

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.