Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11152 closed enhancement (fixed)

Validator gives warning of Style for outer way mismatches polygon

Reported by: Glassman Owned by: Glassman
Priority: normal Milestone: 15.02
Component: Core validator Version: tested
Keywords: multipolygon Cc:

Description

When validating a multipolygon building, the validator gives the following warning:
Style for outer way mismatches polygon. As far as I can tell the multipolygon is correct. An example of a multipolygon can be found here. http://www.openstreetmap.org/relation/4552857#map=16/47.7088/-122.2390

FYI - All of the tags are contained in the relationship.

Attachments (1)

statusreport.txt (122.2 KB) - added by Glassman 5 years ago.
josm status report

Download all attachments as: .zip

Change History (9)

comment:1 Changed 5 years ago by Klumbumbus

Owner: changed from team to Glassman
Status: newneedinfo

Cannot reproduce with josm-latest.
Please add your statusreport as asked on newticket.

Changed 5 years ago by Glassman

Attachment: statusreport.txt added

josm status report

comment:2 Changed 5 years ago by anonymous

sorry - after searching for dups, I forgot to read the new ticket instructions.

comment:3 Changed 5 years ago by Klumbumbus

Resolution: worksforme
Status: needinfoclosed

This is caused by an error in the mappaint style Styles/AddressValidator. You can try to contact the authors of this style. Or you can simply use Styles/Coloured_Streets instead.

comment:4 Changed 5 years ago by Klumbumbus

Milestone: 15.03
Resolution: worksforme
Status: closedreopened
Type: defectenhancement

We should improve the wording of the validator message. (similar to r8045)

comment:5 Changed 5 years ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

In 8106/josm:

fix #11152 - improve validator message.

comment:6 Changed 5 years ago by Klumbumbus

Milestone: 15.0315.02

comment:7 Changed 5 years ago by Don-vip

we have not yet released the February version, please avoid to make strings change until we release it.

comment:8 Changed 5 years ago by Don-vip

Oh right sorry I didn't see Dirk was planning another i18n. It's fine :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Glassman.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.