Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11096 closed enhancement (fixed)

replace png icons with svg version if available

Reported by: bastiK Owned by: team
Priority: normal Milestone: 15.02
Component: Core Version:
Keywords: image Cc:

Description

We have a bunch of svg images in images_nodist. These should be distributed and replace the png version in images.

Attachments (1)

josm_11096_reverse_relation.png (3.1 KB) - added by skyper 4 years ago.
screenshot

Download all attachments as: .zip

Change History (32)

comment:1 Changed 4 years ago by bastiK

In 8031/josm:

see #11096 - update svg to look like the png version

comment:2 Changed 4 years ago by bastiK

In 8032/josm:

see #11096 - replace png icons with svg version if available

comment:3 Changed 4 years ago by bastiK

In 8033/josm:

see #11096 - replace png icons with svg version if available (2)

comment:4 Changed 4 years ago by bastiK

In 8034/josm:

see #11096 - replace png icons with svg version if available (3)

comment:5 Changed 4 years ago by bastiK

In 8035/josm:

see #11096 - replace png icons with svg version if available (4)

comment:6 Changed 4 years ago by bastiK

Resolution: fixed
Status: newclosed

In 8036/josm:

fixed #11096 - replace png icons with svg version if available

comment:7 Changed 4 years ago by bastiK

In 8037/josm:

see #11096 - replace png icons with svg version if available (5)

comment:8 Changed 4 years ago by skyper

Resolution: fixed
Status: closedreopened

Something went wrong.

What steps will reproduce the problem?

  1. click on resolve conflict in conflict toggle dialog

What is the expected result?

conflict manager window opens

What happens instead?

RuntimeException

Please provide any additional information below. Attach a screenshot if possible.

Did load a session from yesterday, where I did not resolve conflicts before saving.
No problem with r8029.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-02-11 02:34:32
Last Changed Author: Klumbumbus
Revision: 8045
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-02-11 00:55:31 +0100 (Wed, 11 Feb 2015)
Last Changed Rev: 8045

Identification: JOSM/1.5 (8045 en) Linux Debian GNU/Linux 7.8 (wheezy)
Memory Usage: 450 MB / 882 MB (277 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u75-2.5.4-1~deb7u1
Program arguments: [work_to_do.joz]
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (30962)
- conflation (0.1.7)
- download_along (30892)
- imagery-xml-bounds (30892)
- imagery_offset_db (30892)
- jts (30892)
- mirrored_download (30962)
- photoadjust (30964)
- reverter (30953)
- terracer (30892)
- todo (29154)
- undelete (30892)
- utilsplugin2 (30958)
- waydownloader (30892)
- wikipedia (30892)

Last errors/warnings:
- E: java.lang.RuntimeException: Fatal: failed to locate image 'tagkeepmine.png'. This is a serious configuration problem. JOSM will stop working.

java.lang.RuntimeException: Fatal: failed to locate image 'tagkeepmine.png'. This is a serious configuration problem. JOSM will stop working.
	at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:440)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:421)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:513)
	at org.openstreetmap.josm.gui.conflict.pair.tags.TagMerger$KeepMineAction.<init>(TagMerger.java:267)
	at org.openstreetmap.josm.gui.conflict.pair.tags.TagMerger.build(TagMerger.java:169)
	at org.openstreetmap.josm.gui.conflict.pair.tags.TagMerger.<init>(TagMerger.java:234)
	at org.openstreetmap.josm.gui.conflict.pair.ConflictResolver.build(ConflictResolver.java:104)
	at org.openstreetmap.josm.gui.conflict.pair.ConflictResolver.<init>(ConflictResolver.java:133)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog.build(ConflictResolutionDialog.java:121)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog.<init>(ConflictResolutionDialog.java:138)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.resolve(ConflictDialog.java:187)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.access$400(ConflictDialog.java:65)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog$ResolveAction.actionPerformed(ConflictDialog.java:432)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6516)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:740)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:699)
	at java.awt.EventQueue$3.run(EventQueue.java:697)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:713)
	at java.awt.EventQueue$4.run(EventQueue.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:710)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

comment:9 Changed 4 years ago by Klumbumbus

Is there a list, which shows all those missing images in the wiki? http://josm.openstreetmap.de/wiki/WikiStart?action=diff&version=223

I suppose there are more than these two.

comment:10 Changed 4 years ago by bastiK

In 8047/josm:

see #11096 - fix png -> svg

comment:11 in reply to:  9 Changed 4 years ago by stoecker

Replying to Klumbumbus:

Is there a list, which shows all those missing images in the wiki? http://josm.openstreetmap.de/wiki/WikiStart?action=diff&version=223

I suppose there are more than these two.

There is a wantedpages macro, but no wantedimages.

comment:12 Changed 4 years ago by rickmastfan67

Just got a similar 'RuntimeException' to the one that skyper posted in comment:8, however, it has a different trace location on 'line 4'.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-02-13 02:34:07
Last Changed Author: Klumbumbus
Revision: 8055
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-02-12 23:45:22 +0100 (Thu, 12 Feb 2015)
Last Changed Rev: 8055

Identification: JOSM/1.5 (8055 en) Windows 7 64-Bit
Memory Usage: 631 MB / 1820 MB (437 MB allocated, but free)
Java version: 1.7.0_71, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- ImageryCache (30892)
- OpeningHoursEditor (30962)
- buildings_tools (30955)
- measurement (30892)
- mirrored_download (30962)
- notes (v0.9.5)
- osmarender (30892)
- reverter (30953)
- turnrestrictions (30962)
- undelete (30892)
- utilsplugin2 (30958)

Last errors/warnings:
- E: java.lang.RuntimeException: Fatal: failed to locate image 'moveup.png'. This is a serious configuration problem. JOSM will stop working.

java.lang.RuntimeException: Fatal: failed to locate image 'moveup.png'. This is a serious configuration problem. JOSM will stop working.
	at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:440)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:421)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:513)
	at org.openstreetmap.josm.gui.conflict.pair.ListMerger$MoveUpMergedAction.<init>(ListMerger.java:683)
	at org.openstreetmap.josm.gui.conflict.pair.ListMerger.buildMergedListControlButtons(ListMerger.java:214)
	at org.openstreetmap.josm.gui.conflict.pair.ListMerger.build(ListMerger.java:377)
	at org.openstreetmap.josm.gui.conflict.pair.ListMerger.<init>(ListMerger.java:410)
	at org.openstreetmap.josm.gui.conflict.pair.nodes.NodeListMerger.<init>(NodeListMerger.java:19)
	at org.openstreetmap.josm.gui.conflict.pair.ConflictResolver.build(ConflictResolver.java:109)
	at org.openstreetmap.josm.gui.conflict.pair.ConflictResolver.<init>(ConflictResolver.java:133)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog.build(ConflictResolutionDialog.java:121)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog.<init>(ConflictResolutionDialog.java:138)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.resolve(ConflictDialog.java:187)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.access$400(ConflictDialog.java:65)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog$ResolveAction.actionPerformed(ConflictDialog.java:432)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

comment:13 Changed 4 years ago by bastiK

Resolution: fixed
Status: reopenedclosed

In 8056/josm:

fixed #11096 - png -> svg

comment:14 Changed 4 years ago by bastiK

Sorry about the broken wiki links. It would be nice to have a way to find all dead links, but I don't know how.

comment:15 Changed 4 years ago by Klumbumbus

Well, you can search for the old icon like this way: http://josm.openstreetmap.de/search?q=source%3Ajosm%2Ftrunk%2Fimages%2Fdata%2Fchangeset.png&noquickjump=1&wiki=on

But this is still not the most comfortable way.

comment:16 Changed 4 years ago by Klumbumbus

Ticket #11115 has been marked as a duplicate of this ticket.

comment:17 Changed 4 years ago by rickmastfan67

Resolution: fixed
Status: closedreopened

Still broken. :( Because of this, still can't resolve conflicts with the latest builds.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-02-14 02:34:58
Last Changed Author: Klumbumbus
Revision: 8060
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-02-14 00:42:30 +0100 (Sat, 14 Feb 2015)
Last Changed Rev: 8060

Identification: JOSM/1.5 (8060 en) Windows 7 64-Bit
Memory Usage: 510 MB / 1820 MB (268 MB allocated, but free)
Java version: 1.7.0_71, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- ImageryCache (30892)
- OpeningHoursEditor (30962)
- buildings_tools (30955)
- measurement (30892)
- mirrored_download (30962)
- notes (v0.9.5)
- osmarender (30892)
- reverter (30953)
- turnrestrictions (30962)
- undelete (30892)
- utilsplugin2 (30958)

Last errors/warnings:
- E: java.lang.RuntimeException: Fatal: failed to locate image 'mergeincomplete.png'. This is a serious configuration problem. JOSM will stop working.

java.lang.RuntimeException: Fatal: failed to locate image 'mergeincomplete.png'. This is a serious configuration problem. JOSM will stop working.
	at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:440)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:421)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:513)
	at org.openstreetmap.josm.gui.conflict.pair.ConflictResolver.loadIcons(ConflictResolver.java:90)
	at org.openstreetmap.josm.gui.conflict.pair.ConflictResolver.<init>(ConflictResolver.java:134)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog.build(ConflictResolutionDialog.java:121)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog.<init>(ConflictResolutionDialog.java:138)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.resolve(ConflictDialog.java:187)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.access$400(ConflictDialog.java:65)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog$ResolveAction.actionPerformed(ConflictDialog.java:432)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

comment:18 Changed 4 years ago by bastiK

In 8061/josm:

see #11096 - strip .png

comment:19 Changed 4 years ago by skyper

There are still duplicates like speech.png <-> speech.svg and some more regarding markers and layers.

comment:20 in reply to:  19 ; Changed 4 years ago by bastiK

Replying to skyper:

There are still duplicates like speech.png <-> speech.svg and some more regarding markers and layers.

I don't understand, could you link the files?

comment:21 Changed 4 years ago by Don-vip

Ticket #11121 has been marked as a duplicate of this ticket.

comment:22 Changed 4 years ago by mdk

Does this belongs to this issue (now running r8067)?

Last errors/warnings:

  • E: Failed to locate image 'maxspeed_icon.svg'
  • W: Mappaint style "standard" (Maxspeed) icon "maxspeed_icon.svg" not found.

comment:23 in reply to:  22 Changed 4 years ago by Klumbumbus

Replying to mdk:

Does this belongs to this issue (now running r8067)?

Last errors/warnings:

  • E: Failed to locate image 'maxspeed_icon.svg'
  • W: Mappaint style "standard" (Maxspeed) icon "maxspeed_icon.svg" not found.

No, this is 10581#comment:22

comment:24 in reply to:  20 Changed 4 years ago by skyper

Replying to bastiK:

Replying to skyper:

There are still duplicates like speech.png <-> speech.svg and some more regarding markers and layers.

I don't understand, could you link the files?

My bad in reading commits. Sorry.

Changed 4 years ago by skyper

screenshot

comment:25 Changed 4 years ago by skyper

Have a problem with the rendering of source:trunk/images/dialogs/relation/reverse.svg reverse.svg. Have a look:

screenshot

comment:26 in reply to:  25 Changed 4 years ago by bastiK

Replying to skyper:

Have a problem with the rendering of source:trunk/images/dialogs/relation/reverse.svg reverse.svg. Have a look:

Should be fixed with svgsalamander update in [8083].

comment:27 Changed 4 years ago by Don-vip

Is this ticket fixed?

comment:28 Changed 4 years ago by bastiK

Resolution: fixed
Status: reopenedclosed

comment:29 Changed 4 years ago by Klumbumbus

It seems you forgot closechangeset.svg

comment:30 in reply to:  29 ; Changed 4 years ago by bastiK

Replying to Klumbumbus:

It seems you forgot closechangeset.svg

It's not the same image, the png version has extra red squares on top.

comment:31 in reply to:  30 Changed 4 years ago by Klumbumbus

Replying to bastiK:

It's not the same image, the png version has extra red squares on top.

Ah, right.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.