Modify

Opened 6 years ago

Closed 6 years ago

#11121 closed defect (duplicate)

Regression: Exception when opening a conflict

Reported by: mdk Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I got a conflict. When I try to "Resolve" the conflict, I get the below Exception.

I test the same with last stable version r7995 without problems.

To Reproduce, I striped down a saved file (see attachment). Load the file and choose *Update Data" from File menu. You will get a conflict. Try to resolve the conflict.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-02-14 02:34:58
Last Changed Author: Klumbumbus
Revision: 8060
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-02-14 00:42:30 +0100 (Sat, 14 Feb 2015)
Last Changed Rev: 8060

Identification: JOSM/1.5 (8060 en) Linux Ubuntu 14.10
Memory Usage: 334 MB / 880 MB (141 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK Server VM
Java package: openjdk-7-jre:i386-7u75-2.5.4-1~utopic1
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/michael/.josm-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- ColumbusCSV (30892)
- FastDraw (30892)
- HouseNumberTaggingTool (30892)
- OpeningHoursEditor (30962)
- RoadSigns (30977)
- SimplifyArea (30962)
- buildings_tools (30955)
- contourmerge (1012)
- imagery-xml-bounds (30892)
- imagery_offset_db (30892)
- poly (30892)
- public_transport (30892)
- reltoolbox (30892)
- reverter (30953)
- scoutsigns (43)
- terracer (30892)
- turnrestrictions (30962)
- utilsplugin2 (30958)

Last errors/warnings:
- W: Mappaint style "standard" (Maxspeed) icon "maxspeed_icon.svg" not found.
- E: java.lang.RuntimeException: Fatal: failed to locate image 'mergeincomplete.png'. This is a serious configuration problem. JOSM will stop working.
- E: java.lang.RuntimeException: Fatal: failed to locate image 'mergeincomplete.png'. This is a serious configuration problem. JOSM will stop working.
- E: java.lang.RuntimeException: Fatal: failed to locate image 'mergeincomplete.png'. This is a serious configuration problem. JOSM will stop working.
- E: java.lang.RuntimeException: Fatal: failed to locate image 'mergeincomplete.png'. This is a serious configuration problem. JOSM will stop working.

java.lang.RuntimeException: Fatal: failed to locate image 'mergeincomplete.png'. This is a serious configuration problem. JOSM will stop working.
	at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:440)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:421)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:513)
	at org.openstreetmap.josm.gui.conflict.pair.ConflictResolver.loadIcons(ConflictResolver.java:90)
	at org.openstreetmap.josm.gui.conflict.pair.ConflictResolver.<init>(ConflictResolver.java:134)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog.build(ConflictResolutionDialog.java:121)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog.<init>(ConflictResolutionDialog.java:138)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.resolve(ConflictDialog.java:187)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.access$400(ConflictDialog.java:65)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog$MouseEventHandler.mouseClicked(ConflictDialog.java:353)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270)
	at java.awt.Component.processMouseEvent(Component.java:6519)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4501)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:740)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:699)
	at java.awt.EventQueue$3.run(EventQueue.java:697)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:713)
	at java.awt.EventQueue$4.run(EventQueue.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:710)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (1)

temp.osm (877 bytes) - added by mdk 6 years ago.

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by mdk

Attachment: temp.osm added

comment:1 Changed 6 years ago by mdk

It looks like an icon is missing: mergeincomplete.png

Also in Last errors/warnings: maxspeed_icon.svg not found

comment:2 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11096.
If you're running JOSM latest, please make sure to use the latest version before reporting a bug: this already has been fixed in r8061.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.