Modify

Opened 6 years ago

Closed 6 years ago

#11115 closed defect (duplicate)

Bug report request on solve conflict

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Simple trying to solve the first conflict showed on list

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-02-13 02:34:07
Last Changed Author: Klumbumbus
Revision: 8055
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-02-12 23:45:22 +0100 (Thu, 12 Feb 2015)
Last Changed Rev: 8055

Identification: JOSM/1.5 (8055 it) Linux Ubuntu 14.10
Memory Usage: 254 MB / 455 MB (69 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, Java HotSpot(TM) Server VM
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (30892)
- CommandLine (30892)
- FastDraw (30892)
- FixAddresses (30892)
- ImportImagePlugin (30892)
- OpeningHoursEditor (30962)
- PicLayer (30962)
- SimplifyArea (30962)
- areaselector (1423773025)
- buildings_tools (30955)
- conflation (0.1.7)
- continuosDownload (1413902943)
- contourmerge (1012)
- dataimport (30892)
- download_along (30892)
- geotools (30892)
- imagery_offset_db (30892)
- jts (30892)
- junctionchecking (30892)
- livegps (30892)
- log4j (30892)
- mapdust (30892)
- merge-overlap (30892)
- mirrored_download (30962)
- namemanager (30892)
- notes (v0.9.5)
- opendata (30911)
- pbf (30892)
- pdfimport (30892)
- poly (30892)
- print (30892)
- proj4j (30892)
- reltoolbox (30892)
- reverter (30953)
- scripting (30702)
- tageditor (30892)
- tagging-preset-tester (30892)
- terracer (30892)
- turnrestrictions (30962)
- undelete (30892)
- utilsplugin2 (30958)
- walkingpapers (30892)
- waydownloader (30892)
- waypoint_search (30892)
- wikipedia (30892)

Last errors/warnings:
- W: java.io.IOException: Server returned HTTP response code: 412 for URL: https://api.openstreetmap.org/api/0.6/changeset/28827009/upload. Causa: java.io.IOException: Server returned HTTP response code: 412 for URL: https://api.openstreetmap.org/api/0.6/changeset/28827009/upload
- E: Error header: Precondition failed: Node 3347477398 is still used by ways 327928610.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 3347477398 is still used by ways 327928610.>
- E: java.lang.RuntimeException: Errore grave: non è stato possibile trovare l'immagine 'moveup.png'. Questo è un serio problema di configurazione. JOSM terminerà di funzionare.
- E: java.lang.RuntimeException: Errore grave: non è stato possibile trovare l'immagine 'moveup.png'. Questo è un serio problema di configurazione. JOSM terminerà di funzionare.

java.lang.RuntimeException: Errore grave: non è stato possibile trovare l'immagine 'moveup.png'. Questo è un serio problema di configurazione. JOSM terminerà di funzionare.
	at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:440)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:421)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:513)
	at org.openstreetmap.josm.gui.conflict.pair.ListMerger$MoveUpMergedAction.<init>(ListMerger.java:683)
	at org.openstreetmap.josm.gui.conflict.pair.ListMerger.buildMergedListControlButtons(ListMerger.java:214)
	at org.openstreetmap.josm.gui.conflict.pair.ListMerger.build(ListMerger.java:377)
	at org.openstreetmap.josm.gui.conflict.pair.ListMerger.<init>(ListMerger.java:410)
	at org.openstreetmap.josm.gui.conflict.pair.nodes.NodeListMerger.<init>(NodeListMerger.java:19)
	at org.openstreetmap.josm.gui.conflict.pair.ConflictResolver.build(ConflictResolver.java:109)
	at org.openstreetmap.josm.gui.conflict.pair.ConflictResolver.<init>(ConflictResolver.java:133)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog.build(ConflictResolutionDialog.java:121)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog.<init>(ConflictResolutionDialog.java:138)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.resolve(ConflictDialog.java:187)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.access$400(ConflictDialog.java:65)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog$ResolveAction.actionPerformed(ConflictDialog.java:432)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6505)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3320)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11096.
see comment 12 and 13

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.