Modify

Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#11114 closed defect (fixed)

Copying Tags with Relations Editor

Reported by: daganzdaanda Owned by: team
Priority: normal Milestone: 16.07
Component: Core Version: tested
Keywords: relation editor paste tags focus Cc: akks

Description

Hi,
I've got two copying issues with the relation editor (current stable).

First, say I want to move all tags of a way to a relation.

So I select the way, choose "copy all keys/values" in the tags window, and then in the relation window, I press the "paste tags from buffer" button. The result: the first key is left empty, the values are all there.
It looks like http://josm.openstreetmap.de/ticket/9176, except that pressing "Esc" does not make the missing key show up.

Second issue: Is there a way to easily copy all keys/values from a relation to a way via the relation editor? I can select all keys/values with the mouse and press Ctrl-C, but pasting does not work since there is no usable data in the buffer. I know that copying all k/v is possible from the tags window if the relation is selected, but maybe that could be an improvement to the workflow with the relations editor.

Attachments (0)

Change History (10)

comment:1 Changed 5 years ago by skyper

The relation editor is the wrong place to do the job and not needed at all.

For both ways you simply need to select the relation using the relation list dialog. Once selected you can work with relations in the same way as other objects.

comment:2 Changed 5 years ago by Don-vip

Resolution: worksforme
Status: newclosed

comment:3 Changed 5 years ago by daganzdaanda

Ah, ok, thanks for the tip! I'll try and change my workflow.

But - does the +++ button (paste tags from buffer) work as it should for you? If there's always one key that disappears, maybe it would be better to remove the button altogether and make it clear that copying tags is better done without the relation editor.

comment:4 in reply to:  3 Changed 5 years ago by skyper

Replying to daganzdaanda:

But - does the +++ button (paste tags from buffer) work as it should for you? If there's always one key that disappears, maybe it would be better to remove the button altogether and make it clear that copying tags is better done without the relation editor.

Yes, there is definitely a problem with paste buffer and the relation manager.

comment:5 Changed 5 years ago by stoecker

Resolution: worksforme
Status: closedreopened

comment:6 Changed 5 years ago by Don-vip

Keywords: relation editor paste tags added; Relation Editor copying keys/values removed

indeed, closed too fast, I'm able to reproduce the bug.

comment:7 Changed 5 years ago by Don-vip

Cc: akks added
Keywords: focus added

however I'm unable to fix it. It looks like related to the focus handling of cells in TagTable: if I select the first cell of the last line prior to pasting tags, it will always result in an empty key (but the value is pasted).

Can't figure why. akks, do you have any idea?

comment:8 Changed 3 years ago by michael2402

I will fix this when updating the copy/paste patch. See #12478

A simple editor.stopCellEditing() before doing any manual data updates is enough.

comment:9 Changed 3 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 10604/josm:

fix #12478, fix #12565, fix #11114 - Use ​Swing Copy/Paste instead of CopyAction/PasteAction with custom buffer (patch by michael2402, modified) - gsoc-core

comment:10 Changed 3 years ago by Don-vip

Milestone: 16.07

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.