Modify

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#10519 closed defect (fixed)

Session: wms-layer not working after loading

Reported by: skyper Owned by: team
Priority: normal Milestone: 15.08
Component: Core imagery Version: latest
Keywords: template_report session WMS layer Cc:

Description

In #10410 storing wms-layer settings was implemented but after loading the layer does not work:

What steps will reproduce the problem?

  1. java -Djosm.home=/tmp/.josm-test -jar josm-latest.jar
  2. download some data within Baden-Württemberg
  3. add wms-layer "Maps4BW"
  4. check off "automatic downloading" and "automatically change resolution"
  5. change to expert mode
  6. save session (wms_session.joz)
  7. exit
  8. java -Djosm.home=/tmp/.josm-test -jar josm-latest.jar wms_session.joz
  9. check "automatic downloading"

What is the expected result?

Previous downloaded tiles should be visible right away from cache and new ones should be downloaded after checking the checkbox

What happens instead?

No tiles at all.

Please provide any additional information below. Attach a screenshot if possible.

Adding a duplicate wms layer works.
As I just noticed even the cached tiles are not shown.

Please find my session file and my preference directory attached

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-09-16 01:33:52
Last Changed Author: Don-vip
Revision: 7543
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-09-16 03:29:51 +0200 (Tue, 16 Sep 2014)
Last Changed Rev: 7543

Identification: JOSM/1.5 (7543 en) Linux Debian GNU/Linux 7.6 (wheezy)
Memory Usage: 107 MB / 882 MB (19 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u65-2.5.1-5~deb7u1
VM arguments: [-Djosm.home=/tmp/.josm-test]
Program arguments: [--language=en, wms_session.joz]
Dataset consistency test: No problems found


Last errors/warnings:
- E: Failed to locate image 'null'

Attachments (1)

sample_conf.tar (350.0 KB) - added by skyper 7 years ago.
config + session file

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by skyper

Attachment: sample_conf.tar added

config + session file

comment:1 Changed 7 years ago by Don-vip

Component: CoreCore imagery

comment:2 Changed 7 years ago by Don-vip

Ticket #11106 has been marked as a duplicate of this ticket.

comment:3 Changed 6 years ago by wiktorn

Milestone: 15.07
Resolution: fixed
Status: newclosed

Looks like it is solved right now in josm-latest.

comment:4 Changed 6 years ago by Don-vip

Milestone: 15.0715.08

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.