Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10410 closed defect (fixed)

session: imagery layer settings not stored

Reported by: skyper Owned by: team
Priority: normal Milestone: 14.08
Component: Core Version: latest
Keywords: template_report session WMS layer settings Cc:

Description

What steps will reproduce the problem?

  1. enable a WMS-layer
  2. uncheck "auto download" and "change resolution"
  3. save session
  4. exit
  5. start JOSM with saved session

What is the expected result?

WMS-layer settings are restored

What happens instead?

default layer settings are applied and resolution is changed.

Please provide any additional information below. Attach a screenshot if possible.

As #4029 is still open this might belong to it.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-08-22 01:36:32
Last Changed Author: Don-vip
Revision: 7437
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-08-22 00:58:24 +0200 (Fri, 22 Aug 2014)
Last Changed Rev: 7437

Identification: JOSM/1.5 (7437 en) Linux Debian GNU/Linux 7.6 (wheezy)
Memory Usage: 177 MB / 882 MB (57 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u65-2.5.1-2~deb7u1

Plugins:
- OpeningHoursEditor (30519)
- conflation (0.1.7)
- imagery-xml-bounds (30495)
- jts (30416)
- mirrored_download (30495)
- notes (v0.9.3)
- photoadjust (30428)
- reverter (30521)
- terracer (30416)
- todo (29154)
- undelete (30416)
- utilsplugin2 (30460)
- wikipedia (30449)

Last errors/warnings:
- W: Detected deprecated 'canvas{background-color}' in 'https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip' which will be removed shortly. Use 'fill-color' instead.

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by bastiK

Resolution: fixed
Status: newclosed

In 7438/josm:

fixed #10410 - session: imagery layer settings not stored

comment:2 Changed 5 years ago by Don-vip

Milestone: 14.08

comment:3 Changed 5 years ago by skyper

Resolution: fixed
Status: closedreopened

Now, the settings are stored but checking "automatic downloading" does not start downloading.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-09-04 01:34:19
Last Changed Author: Don-vip
Revision: 7489
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-09-04 01:12:48 +0200 (Thu, 04 Sep 2014)
Last Changed Rev: 7489

Identification: JOSM/1.5 (7489 en) Linux Debian GNU/Linux 7.6 (wheezy)
Memory Usage: 352 MB / 882 MB (74 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u65-2.5.1-5~deb7u1
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (30609)
- conflation (0.1.7)
- imagery-xml-bounds (30495)
- jts (30416)
- mirrored_download (30495)
- notes (v0.9.4)
- photoadjust (30428)
- reverter (30521)
- terracer (30614)
- todo (29154)
- undelete (30416)
- utilsplugin2 (30460)
- wikipedia (30449)

Last errors/warnings:
- W: Detected deprecated 'canvas{background-color}' in 'https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip' which will be removed shortly. Use 'fill-color' instead.
- E: Failed to locate image 'null'

comment:4 in reply to:  3 ; Changed 5 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Replying to skyper:

Now, the settings are stored but checking "automatic downloading" does not start downloading.

Works for me, so I close this ticket again. If you reproduce, please open a new ticket with precise reproduction steps. Thanks.

comment:5 in reply to:  4 Changed 5 years ago by skyper

Replying to Don-vip:

Replying to skyper:

Now, the settings are stored but checking "automatic downloading" does not start downloading.

Works for me, so I close this ticket again. If you reproduce, please open a new ticket with precise reproduction steps. Thanks.

Maybe it is only a special source not working, anyway, follow-up is #10519.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.