Modify

Opened 7 years ago

Closed 7 years ago

#10411 closed defect (duplicate)

Unable to connect to remote control from tasks.hotosm.org

Reported by: meetar Owned by: team
Priority: normal Milestone:
Component: Core remotecontrol Version:
Keywords: localhost Cc:

Description

What steps will reproduce the problem?

  1. Start JOSM
  2. Ensure "Enable remote control" is checked
  3. Ensure OSM login information is correct
  4. Lock a task on http://tasks.hotosm.org/ and click the "Edit with JOSM" button

What is the expected result?
JOSM will download the data.

What happens instead?
The web page displays an alert: "JOSM remote control did not respond. Do you have JOSM running and configured to be controlled remotely?"

Please provide any additional information below. Attach a screenshot if
possible.

  • I am able to download data from OSM through the "Download from OSM…" menu item.
  • A Windows 7 box on the same network can download the task to JOSM successfully. The remote control and connection settings are the same on both machines. Testing the 8111 and 8112 ports at canyouseeme.org returns the same result on both machines: "Error: could not see service on port 8111, Reason: Connection timed out"
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-07-28 22:35:35
Last Changed Author: Don-vip
Revision: 7347
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-07-29 00:32:15 +0200 (Tue, 29 Jul 2014)
Last Changed Rev: 7347

Identification: JOSM/1.5 (7347 en) Mac OS X 10.9.4
Memory Usage: 182 MB / 910 MB (49 MB allocated, but free)
Java version: 1.7.0_67, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.library.path=/Users/pjrich/Applications/josm-macosx/JOSM.app/Contents/MacOS, -DLibraryDirectory=/Users/pjrich/Library, -DDocumentsDirectory=/Users/pjrich/Documents, -DApplicationSupportDirectory=/Users/pjrich/Library/Application Support, -DCachesDirectory=/Users/pjrich/Library/Caches, -DSandboxEnabled=false, -Xmx1024m, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]

Attachments (0)

Change History (12)

comment:1 Changed 7 years ago by mkoniecz

Seems to be duplicate of #10033

See http://josm.openstreetmap.de/ticket/10033#comment:22 for affected browsers, OS combinations and https://github.com/openstreetmap/openstreetmap-website/issues/803 for workaround.

Last edited 7 years ago by mkoniecz (previous) (diff)

comment:2 Changed 7 years ago by meetar

If I'm reading it correctly, in #10033, JOSM opens but no data is sent. In this issue, JOSM can't be contacted at all.

Last edited 7 years ago by Don-vip (previous) (diff)

comment:3 Changed 7 years ago by meetar

Additionally, visiting https://127.0.0.1:8112/ or https://localhost:8112/ in any browser fails:
Firefox: "Unable to connect - Firefox can't establish a connection to the server at 127.0.0.1:8112."
Chrome: "This webpage is not available - Chrome's connection attempt to 127.0.0.1 was rejected. Error code: ERR_CONNECTION_REFUSED"
Safari: "Safari can't connect to the server"

comment:4 Changed 7 years ago by mkoniecz

In any case you need to start JOSM before attempting to use remote control.

comment:5 Changed 7 years ago by meetar

Of course – and to be clear, the browser tests were run while JOSM was open, with the remote control activated.

comment:6 Changed 7 years ago by stoecker

According to the description it looks more like a personal firewall or anything similar. Use your system tools (i.e. netstat) to see if the port is open or not and if it is the right port and if there is a firewall preventing access.

comment:7 Changed 7 years ago by Don-vip

Resolution: othersoftware
Status: newclosed

Either a problem with firewall configuration or a problem from HOT website. Note that https remote control support for Mac OSX is not yet implemented/tested (#10033).

comment:8 Changed 7 years ago by Meetar

The firewall is off. There is no other firewall. A windows machine and another Mac OS device on the same network were able to connect, but I no longer have access to the other Mac device for troubleshooting. In that case, if the Mac functionality is "not implemented", suggest changing this from "other software" to "wontfix" or equivalent, to make it clear for others who may find this bug and wonder what's wrong.

comment:9 Changed 7 years ago by Polarbear-j

Could this #10833 be the reason? I was looking for firewall issues first as well but could exclude them, until I could reproduce the problem as described there.

Last edited 7 years ago by Polarbear-j (previous) (diff)

comment:10 Changed 7 years ago by Polarbear-j

Resolution: othersoftware
Status: closedreopened

comment:11 Changed 7 years ago by Polarbear-j

Component: CoreCore remotecontrol
Keywords: localhost added; template_report removed

comment:12 Changed 7 years ago by Don-vip

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #10833.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.