Modify

Opened 6 years ago

Last modified 5 months ago

#10435 new enhancement

Improvements to user-settings for mapcss mappaint styles

Reported by: Klumbumbus Owned by: team
Priority: normal Milestone:
Component: Core mappaint Version:
Keywords: style settings mapcss Cc: skyper, imagic, richlv

Description (last modified by Klumbumbus)

User-settings for mapcss mappaint styles were included in JOSM with very basic functionality (see #10421). While this was ok for its first use, it could need some improvements which I want to sum up here:

  • Currently it is only accessible in mappaint dialog. Many users do not use the dialog or even do not know how to get it. (Although I described where to change the user setting and attached a screenshot in the forum, users searched in the preferences window to change the user setting and gave up searching). It would be useful if the user-settings are also accessible in the preferences window and in the view menu (maybe also for buttons placed in the toolbar). To make it accessible in the preferences window (which is maybe indeed the first place to search for this setting) is maybe relevant for milestone:14.08 since it includes the big changes in default mappaint style.
  • Enable to set a keyboard shortcut to change a specific (boolean) user setting.
  • Enable grouping of similar settings for enabling/disabling several settings at once. Done in r15289

Attachments (0)

Change History (29)

comment:1 Changed 6 years ago by Don-vip

I agree on point 1 we should make it more accessible. I don't understand the difference between point 4 and #10426 you created earlier?

comment:2 in reply to:  1 Changed 6 years ago by Klumbumbus

Replying to Don-vip:

I don't understand the difference between point 4 and #10426 you created earlier?

#10426 was not about user settings but about strings to display on nodes, ways and areas. I would like to use it in Styles/Coloured_Streets. You can see there in the screenshoots that it displays strings on nodes, ways and areas like "street?" or "number?" or "addr:interpolation shouldn't have other addr:*=* tags!"

I don't know if there is a difference in implementation if tr() is used in a mappaint user setting or in a normal block like way[highway=residential][!name]{ text: tr("name?"); } (Help/Styles/MapCSSImplementation says tr()is only for strings in the JOSM user interface).
If there is no difference, then #10426 can be closed as duplicate of this ticket.

comment:3 Changed 6 years ago by skyper

Cc: skyper added

comment:4 in reply to:  description Changed 6 years ago by bastiK

Replying to Klumbumbus:

  • Currently it is only accessible in mappaint dialog. Many users do not use the dialog or even do not know how to get it. (Although I described where to change the user setting and attached a screenshot in the forum, users searched in the preferences window to change the user setting and gave up searching). It would be useful if the user-settings are also accessible in the preferences window and in the view menu (maybe also for buttons placed in the toolbar). To make it accessible in the preferences window (which is maybe indeed the first place to search for this setting) is maybe relevant for milestone:14.08 since it includes the big changes in default mappaint style.

Technically, it is not so easy to have this setting available in the preference window. (At the moment, it is only aware of the metadata, either downloaded from the server or saved to the preferences.xml. The mapcss file is not parsed before the user hits Okay.)
I won't have time for this before the 14.08 release.

comment:5 Changed 6 years ago by Don-vip

No problem, the version is stable enough, release in progress :)

comment:6 Changed 6 years ago by Klumbumbus

Description: modified (diff)

added to ticket text: Add documentation at Help/Styles/MapCSSImplementation

comment:7 Changed 6 years ago by skyper

Cc: imagic added

comment:8 Changed 6 years ago by Klumbumbus

Description: modified (diff)

comment:9 Changed 13 months ago by G_Fyyar

Is anyone still working on this? Or is there a newer ticket pertaining to enhancing mapcss user-settings?

comment:10 Changed 12 months ago by Don-vip

I plan to work on making style settings more accessible (first point of this ticket).

comment:11 Changed 12 months ago by Don-vip

Description: modified (diff)
Keywords: style settings mapcss added

comment:12 Changed 12 months ago by G_Fyyar

Do you know if anyone is/was planning on expanding the user settings (second point of this ticket)?

comment:13 Changed 12 months ago by Don-vip

In 15288/josm:

see #10435 - keep the style settings menu open after one has been selected, like for mappaint menu

comment:14 in reply to:  13 Changed 12 months ago by Klumbumbus

Replying to Don-vip:

keep the style settings menu open

Thats a nice feature.

comment:15 Changed 12 months ago by Don-vip

In 15289/josm:

see #10435 - Enable grouping of similar settings for enabling/disabling several settings at once

comment:16 Changed 12 months ago by Don-vip

Description: modified (diff)

comment:17 Changed 12 months ago by Klumbumbus

Description: modified (diff)

comment:18 Changed 12 months ago by G_Fyyar

I'm sorry--there was some miscommunication on my end. I meant to say, do you know if anyone is/was planning on expanding the user settings (second point of this ticket)? If not, I'll be working on it.

comment:19 Changed 12 months ago by Don-vip

I don't plan to work on it right now, a patch would be welcome.

comment:20 in reply to:  18 Changed 11 months ago by Klumbumbus

Replying to G_Fyyar:

expanding the user settings (second point of this ticket)? If not, I'll be working on it.

Possible use case see ticket:18095#comment:4

comment:21 Changed 11 months ago by richlv

Cc: richlv added

comment:22 Changed 11 months ago by Don-vip

In 15330/josm:

see #10435 - add more "stay open" menu item classes

comment:23 Changed 11 months ago by Don-vip

In 15331/josm:

fix #18032, see #10435 - proper update of StayOpenCheckBoxMenuItemUI - fix rendering issue on macOS

comment:24 Changed 11 months ago by Don-vip

In 15339/josm:

see #10435 - fix Findbugs violation VO_VOLATILE_REFERENCE_TO_ARRAY

comment:25 Changed 9 months ago by Don-vip

In 15492/josm:

see #18032, see #10435 - fix mappaint popup menu disappearance on macOS

macOS triggers a spurious sun.awt.UngrabEvent that is catched by BasicPopupMenuUI.MouseGrabber
and makes the popup menu disappear. Probably related to https://bugs.openjdk.java.net/browse/JDK-8225698

comment:26 Changed 7 months ago by simon04

In 15731/josm:

see #10435, fix #18095 - MapCSS: add settings of type string/double

comment:27 in reply to:  26 Changed 5 months ago by Klumbumbus

Replying to simon04:

In 15731/josm:

see #10435, fix #18095 - MapCSS: add settings of type string/double

Could you please add documentation on wiki:/Help/Styles/MapCSSImplementation#Stylesettings?

comment:29 Changed 5 months ago by Klumbumbus

Thx.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to Klumbumbus
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket
The owner will be changed from team to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.