Modify

Opened 5 years ago

Closed 10 months ago

#10426 closed enhancement (duplicate)

support translation of strings in external mappaint styles

Reported by: Klumbumbus Owned by: team
Priority: normal Milestone:
Component: Core mappaint Version:
Keywords: i18n Cc: imagic, stoecker

Description

It would be nice if you could translate strings into different languages in external mappaint styles, which are located at http://josm.openstreetmap.de/wiki/Styles, or does it somehow work already? I couldn't find out how.
If I use tr() in a mapcss file will this automatically pushed to launchpad for translation? Or could I attach a .po file with the translations to the wikipage of the mappaint style?

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by Klumbumbus

The style Styles/Coloured_Streets now uses some tr() in the code (for settings and for some texts). If tr() for external mppaint styles is implemented one day you can test the implementation there :)

comment:2 Changed 5 years ago by skyper

Cc: imagic added

Styles/Lane_and_Road_Attributes would benefit from this.

comment:3 Changed 10 months ago by Don-vip

Cc: stoecker added
Keywords: i18n added

comment:4 Changed 10 months ago by Don-vip

Dupe of #11392?

comment:5 Changed 10 months ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11392.
seems so

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.