Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10427 closed defect (fixed)

Problems deleting a photo layer

Reported by: skyper Owned by: team
Priority: normal Milestone: 14.08
Component: Core image mapping Version: latest
Keywords: template_report delete layer Cc:

Description

What steps will reproduce the problem?

  1. load some pictures
  2. open photo toggle dialog
  3. delete photo layer
  4. try to jump to next picture in toggle dialog
  5. load some pictures

What is the expected result?

After 3. the picture should not be shown anymore and after 5. the pictures need to be reloaded in toggle dialog

What happens instead?

Still visible in 4. (leading to NPE below ?) and not reloaded after 5.

Please provide any additional information below. Attach a screenshot if possible.

You always have to close the toggle dialog and open a new one to reload.
I am not really sure when the exception occurred as it was only shown in the terminal but not within the GUI.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-08-26 01:34:47
Last Changed Author: Don-vip
Revision: 7442
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-08-26 01:32:24 +0200 (Tue, 26 Aug 2014)
Last Changed Rev: 7442

Identification: JOSM/1.5 (7442 en) Linux Debian GNU/Linux 7.6 (wheezy)
Memory Usage: 437 MB / 882 MB (187 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u65-2.5.1-2~deb7u1
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (30519)
- conflation (0.1.7)
- imagery-xml-bounds (30495)
- jts (30416)
- mirrored_download (30495)
- notes (v0.9.4)
- photoadjust (30428)
- reverter (30521)
- terracer (30416)
- todo (29154)
- undelete (30416)
- utilsplugin2 (30460)
- wikipedia (30449)

Last errors/warnings:
- E: Failed to locate image 'null'
- W: java.lang.reflect.InvocationTargetException. Cause: java.lang.NullPointerException
- W: java.lang.reflect.InvocationTargetException. Cause: java.lang.NullPointerException
- W: java.lang.reflect.InvocationTargetException. Cause: java.lang.NullPointerException
WARNING: java.lang.reflect.InvocationTargetException. Cause: java.lang.NullPointerException
java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1276)
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1251)
	at org.openstreetmap.josm.gui.MapStatus$Collector.run(MapStatus.java:281)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.data.osm.Storage$PrimitiveIdHash.getHashCode(Storage.java:77)
	at org.openstreetmap.josm.data.osm.Storage$PrimitiveIdHash.getHashCode(Storage.java:73)
	at org.openstreetmap.josm.data.osm.Storage.getBucket(Storage.java:282)
	at org.openstreetmap.josm.data.osm.Storage.access$100(Storage.java:71)
	at org.openstreetmap.josm.data.osm.Storage$FMap.get(Storage.java:407)
	at org.openstreetmap.josm.data.osm.DataSet.getPrimitiveById(DataSet.java:915)
	at org.openstreetmap.josm.data.osm.DataSet.getPrimitiveByIdChecked(DataSet.java:924)
	at org.openstreetmap.josm.data.osm.DataSet.addSelected(DataSet.java:763)
	at org.openstreetmap.josm.data.osm.DataSet.addSelected(DataSet.java:738)
	at org.openstreetmap.josm.data.osm.DataSet.addSelected(DataSet.java:748)
	at org.openstreetmap.josm.gui.MapStatus$Collector.popupCycleSelection(MapStatus.java:479)
	at org.openstreetmap.josm.gui.MapStatus$Collector.access$500(MapStatus.java:229)
	at org.openstreetmap.josm.gui.MapStatus$Collector$1.run(MapStatus.java:352)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:302)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by Don-vip

#9564 is related but it's not really a duplicate, the NPE looks unrelated.

comment:2 Changed 5 years ago by Don-vip

Milestone: 14.08

comment:3 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7444/josm:

fix #10427 - Problems deleting a photo layer

comment:4 Changed 5 years ago by Don-vip

If you manage to reproduce the NPE or understand what causes it, please share the info on #9564.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.