Modify

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#9564 closed defect (fixed)

NPE in Storage$PrimitiveIdHash.getHashCode

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone: 14.11
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-11-27 17:47:56
Last Changed Author: Don-vip
Revision: 6418
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-11-26 17:24:06 +0100 (Tue, 26 Nov 2013)
Last Changed Rev: 6418

Identification: JOSM/1.5 (6418 en) Linux Ubuntu 13.10
Memory Usage: 484 MB / 484 MB (184 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, OpenJDK Server VM
Java package: openjdk-7-jre:i386-7u25-2.3.12-4ubuntu3
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/vivi/.josm-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugin: ImportImagePlugin (29854)
Plugin: PicLayer (29854)
Plugin: dataimport (29854)
Plugin: geotools (30147)
Plugin: gpsblam (29832)
Plugin: gpxfilter (29854)
Plugin: imagery_offset_db (29832)
Plugin: jts (29854)
Plugin: log4j (29853)
Plugin: opendata (30097)
Plugin: utilsplugin2 (30177)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.osm.Storage$PrimitiveIdHash.getHashCode(Storage.java:75)
	at org.openstreetmap.josm.data.osm.Storage$PrimitiveIdHash.getHashCode(Storage.java:71)
	at org.openstreetmap.josm.data.osm.Storage.getBucket(Storage.java:282)
	at org.openstreetmap.josm.data.osm.Storage.access$100(Storage.java:69)
	at org.openstreetmap.josm.data.osm.Storage$FMap.get(Storage.java:407)
	at org.openstreetmap.josm.data.osm.DataSet.getPrimitiveById(DataSet.java:790)
	at org.openstreetmap.josm.data.osm.DataSet.getPrimitiveByIdChecked(DataSet.java:800)
	at org.openstreetmap.josm.data.osm.DataSet.addSelected(DataSet.java:653)
	at org.openstreetmap.josm.data.osm.DataSet.setSelected(DataSet.java:595)
	at org.openstreetmap.josm.data.osm.DataSet.setSelected(DataSet.java:615)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog$SelectAction.actionPerformed(ConflictDialog.java:454)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6505)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (2)

9564_repro_7589.png (269.9 KB) - added by Don-vip 5 years ago.
9564_repro_7589_console.txt (858.5 KB) - added by Don-vip 5 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 in reply to:  description Changed 6 years ago by Don-vip

Owner: changed from team to anonymous
Status: newneedinfo

Replying to anonymous:

Build-Date: 2013-11-27 17:47:56
Revision: 6418

Why are you using an old development version ? You're looking for trouble. Please update to current tested or today's latest, but you shouldn't stay on this version.

What were you doing by the way ? Explaining the steps leading to an error is important, it allows us to reproduce it, understand it, then fix it.

comment:2 Changed 6 years ago by Don-vip

Description: modified (diff)
Summary: bug ...NPE in Storage$PrimitiveIdHash.getHashCode with r6418

comment:3 Changed 5 years ago by Don-vip

NPE reproduced with r7442 in #10427 but it's not really a duplicate, the issue looks unrelated.

comment:4 Changed 5 years ago by Don-vip

Summary: NPE in Storage$PrimitiveIdHash.getHashCode with r6418NPE in Storage$PrimitiveIdHash.getHashCode

comment:5 Changed 5 years ago by Don-vip

Wow I'm reproducing it right now. The error happens in loop:

Build-Date: 2014-09-30 21:25:50
Revision: 7586
Is-Local-Build: true

Identification: JOSM/1.5 (7586 SVN en) Windows 8.1 64-Bit
Memory Usage: 669 MB / 2731 MB (486 MB allocated, but free)
Java version: 1.7.0_67, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dfile.encoding=UTF-8]
Program arguments: [--debug]
Dataset consistency test: No problems found

Last errors/warnings:
- W: java.lang.reflect.InvocationTargetException. Cause: java.lang.NullPointerException
- W: java.lang.reflect.InvocationTargetException. Cause: java.lang.NullPointerException
- W: java.lang.reflect.InvocationTargetException. Cause: java.lang.NullPointerException
- W: java.lang.reflect.InvocationTargetException. Cause: java.lang.NullPointerException
- W: java.lang.reflect.InvocationTargetException. Cause: java.lang.NullPointerException

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.MapMover.mouseDragged(MapMover.java:140)
	at java.awt.AWTEventMulticaster.mouseDragged(AWTEventMulticaster.java:320)
	at java.awt.Component.processMouseMotionEvent(Component.java:6564)
	at javax.swing.JComponent.processMouseMotionEvent(JComponent.java:3338)
	at java.awt.Component.processEvent(Component.java:6285)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4509)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Last edited 5 years ago by Don-vip (previous) (diff)

Changed 5 years ago by Don-vip

Attachment: 9564_repro_7589.png added

Changed 5 years ago by Don-vip

Attachment: 9564_repro_7589_console.txt added

comment:6 Changed 5 years ago by Don-vip

In 7590/josm:

see #9564 - fix NPE seen while reproducing error

comment:7 Changed 5 years ago by Don-vip

new one while reproducing #10731:

WARNING: java.lang.reflect.InvocationTargetException. Cause: java.lang.NullPointerException
java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1276)
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1251)
	at org.openstreetmap.josm.gui.MapStatus$Collector.run(MapStatus.java:281)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.data.osm.Storage$PrimitiveIdHash.getHashCode(Storage.java:77)
	at org.openstreetmap.josm.data.osm.Storage$PrimitiveIdHash.getHashCode(Storage.java:1)
	at org.openstreetmap.josm.data.osm.Storage.getBucket(Storage.java:282)
	at org.openstreetmap.josm.data.osm.Storage.access$0(Storage.java:280)
	at org.openstreetmap.josm.data.osm.Storage$FMap.get(Storage.java:407)
	at org.openstreetmap.josm.data.osm.DataSet.getPrimitiveById(DataSet.java:949)
	at org.openstreetmap.josm.data.osm.DataSet.getPrimitiveByIdChecked(DataSet.java:958)
	at org.openstreetmap.josm.data.osm.DataSet.addSelected(DataSet.java:801)
	at org.openstreetmap.josm.data.osm.DataSet.addSelected(DataSet.java:776)
	at org.openstreetmap.josm.data.osm.DataSet.addSelected(DataSet.java:786)
	at org.openstreetmap.josm.gui.MapStatus$Collector.popupCycleSelection(MapStatus.java:478)
	at org.openstreetmap.josm.gui.MapStatus$Collector.access$4(MapStatus.java:451)
	at org.openstreetmap.josm.gui.MapStatus$Collector$1.run(MapStatus.java:351)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:302)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

comment:8 Changed 5 years ago by Don-vip

Milestone: 14.11

comment:9 Changed 5 years ago by Don-vip

Resolution: fixed
Status: needinfoclosed

In 7714/josm:

fix #9564 - NPE

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.