Modify

Opened 7 years ago

Closed 5 years ago

#10428 closed defect (duplicate)

Deleting buildings and trying to resolve a conflict caused an exception

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report conflict Cc:

Description (last modified by Don-vip)

I really wish I could provide good info beyond the automatically collected info, but I don't really know what I was doing so I can't really outline it very well.

I deleted a lot of buildings, upon uploading to OSM I got a conflict error, a way was referencing one of the building nodes I was deleting (I think that is what it was).

I let josm auto load the way for me to resolve the conflict.

After that I do not know what happened exactly, I used the resolve conflict dialog, but had no idea how it worked or was supposed to work.

After that, I had a 3 sided building and it was when I tried to delete the 3 sided building, I got the unhandled exception.

I doubt the screen shot will help, but maybe.

My 3 sided building I tried to delete that caused the exception

Hopefully the stack trace helps you out.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-07-28 22:35:35
Last Changed Author: Don-vip
Revision: 7347
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-07-29 00:32:15 +0200 (Tue, 29 Jul 2014)
Last Changed Rev: 7347

Identification: JOSM/1.5 (7347 en) Windows XP 32-Bit
Memory Usage: 280 MB / 989 MB (48 MB allocated, but free)
Java version: 1.7.0_67, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Xms128m, -Xmx1024m]

Dataset consistency test:
[WARN - ZERO NODES] Way {Way id=298104992 version=1 MVT nodes=[]} has zero nodes


Plugin: ImportImagePlugin (30416)
Plugin: buildings_tools (30485)
Plugin: geotools (30569)
Plugin: jts (30416)
Plugin: log4j (30416)
Plugin: measurement (30416)
Plugin: mirrored_download (30495)
Plugin: opendata (30508)
Plugin: todo (29154)
Plugin: utilsplugin2 (30460)

java.lang.IllegalArgumentException: {Node id=3020093402 version=1 MVD lat=7.339834933591788,lon=-10.789024154513344} is already deleted
	at org.openstreetmap.josm.command.DeleteCommand.executeCommand(DeleteCommand.java:118)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:52)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:43)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:69)
	at org.openstreetmap.josm.actions.mapmode.DeleteAction.doActionPerformed(DeleteAction.java:145)
	at org.openstreetmap.josm.actions.DeleteAction.actionPerformed(DeleteAction.java:29)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

2014-08-26_17h44_20.png (208.2 KB) - added by bgirardot 7 years ago.
My 3 sided building I tried to delete that caused the exception

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by bgirardot

Attachment: 2014-08-26_17h44_20.png added

My 3 sided building I tried to delete that caused the exception

comment:1 Changed 7 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 7 years ago by skyper

Did you by chance delete an object with was involved in remaining conflicts or parent of object with remaining objects ? See #4654.

comment:3 Changed 5 years ago by skyper

Keywords: conflict added
Resolution: duplicate
Status: newclosed

Closed as duplicate of #9705.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.