Modify

Opened 4 months ago

Closed 3 months ago

Last modified 5 weeks ago

#18032 closed defect (fixed)

Visual bug with mapcss style settings on macOS

Reported by: G_Fyyar Owned by: Don-vip
Priority: normal Milestone: 19.09
Component: Core mappaint Version: latest
Keywords: mappaint, stylesettings, macosx Cc:

Description

What steps will reproduce the problem?

  1. Launch JOSM (must have at least r15289)
  2. Open mappaint dialog box
  3. Right-click any internal OR external mappaint style
  4. Attempt to change a setting from ON to OFF

What is the expected result?

Setting goes from ON to OFF.

What happens instead?

Setting remains ON regardless.

Please provide any additional information below. Attach a screenshot if possible.

All settings are defaulted to ON, and cannot be turned to OFF.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-08-08 01:24:18 +0200 (Thu, 08 Aug 2019)
Build-Date:2019-08-08 01:30:54
Revision:15293
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15293 en) Mac OS X 10.14.5
OS Build number: Mac OS X 10.14.5 (18F132)
Memory Usage: 914 MB / 1820 MB (230 MB allocated, but free)
Java version: 1.8.0_221-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 188945226 1920x1080, Display 69937792 2560x1440
Maximum Screen Size: 2560x1440
Dataset consistency test: No problems found

Plugins:
+ FastDraw (34977)
+ Mapillary (1.5.18)
+ apache-commons (34908)
+ apache-http (34908)
+ auto_tools (73)
+ buildings_tools (34982)
+ changeset-viewer (22)
+ editgpx (34908)
+ graphview (34977)
+ gridify (1556174547)
+ jaxb (35014)
+ jna (34908)
+ log4j (34908)
+ markseen (13)
+ openqa (1557250801)
+ osm-obj-info (51)
+ reverter (34999)
+ routing (35039)
+ scripting (30796)
+ tageditor (34977)
+ utilsplugin2 (34977)

Map paint styles:
+ https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Kaart-Styles.mapcss
+ https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Kaart_QC_Dwarf.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Overlapping%20Ways.mapcss

Validator rules:
- ${HOME}/Desktop/KaartValidator/kaart.dwarf.validator.mapcss
+ https://raw.githubusercontent.com/KaartGroup/KaartValidator/master/kaart.dwarf.validator.mapcss

Last errors/warnings:
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property color to type class java.awt.Color: found Keyword{transparent} of type class org.openstreetmap.josm.gui.mappaint.Keyword!

Attachments (0)

Change History (10)

comment:1 Changed 4 months ago by Don-vip

Owner: changed from team to G_Fyyar
Status: newneedinfo

Works for me on Windows. Do you have access to another OS to see if it's macOS-specific?

comment:2 Changed 4 months ago by taylor.smock

It looks like it is a visual bug, (i.e., the setting in the preferences changes, but the checkbox from the "Style Settings" does not).

So, for some reason, the UI thinks that the items are true when they are false. I've done some investigating, but I'm not seeing a reason for it (yet).

comment:3 Changed 4 months ago by Don-vip

OK so that's a side effect of r15288.

comment:4 Changed 4 months ago by taylor.smock

Keywords: macosx added

The problem does not occur on Fedora 30 x86_64 (Java 8 and Java 12) with r15296, so it is likely a Mac OS X specific problem.

comment:5 Changed 4 months ago by skyper

Works for me on Debian Stretch and Buster

comment:6 Changed 4 months ago by Don-vip

Cc: Don-vip taylor.smock removed
Summary: Broken mapcss style settingsVisual bug with mapcss style settings on macOS

comment:7 Changed 4 months ago by Don-vip

Owner: changed from G_Fyyar to Don-vip
Status: needinfoassigned

comment:8 Changed 3 months ago by Don-vip

Milestone: 19.09

comment:9 Changed 3 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 15331/josm:

fix #18032, see #10435 - proper update of StayOpenCheckBoxMenuItemUI - fix rendering issue on macOS

comment:10 Changed 5 weeks ago by Don-vip

In 15492/josm:

see #18032, see #10435 - fix mappaint popup menu disappearance on macOS

macOS triggers a spurious sun.awt.UngrabEvent that is catched by BasicPopupMenuUI.MouseGrabber
and makes the popup menu disappear. Probably related to https://bugs.openjdk.java.net/browse/JDK-8225698

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.