Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9951 closed defect (fixed)

"Join Overlapping Areas" gives strange multipolygons

Reported by: akks Owned by: team
Priority: normal Milestone: 14.05
Component: Core Version: tested
Keywords: join areas Cc: Balaitous

Description (last modified by akks)

People on forum noticed that after fixing exceptions in r6976, Shift-J started to create some strange multipolygonal shapes.

Here are the sample osm files and before-after pictures (before; after shift-J; after shift-J in older JOSM)

Attachments (4)

before.png (7.7 KB) - added by akks 6 years ago.
After.png (9.1 KB) - added by akks 6 years ago.
After_josm6969.png (7.1 KB) - added by akks 6 years ago.
test.osm (3.0 KB) - added by akks 6 years ago.

Download all attachments as: .zip

Change History (16)

Changed 6 years ago by akks

Attachment: before.png added

Changed 6 years ago by akks

Attachment: After.png added

Changed 6 years ago by akks

Attachment: After_josm6969.png added

Changed 6 years ago by akks

Attachment: test.osm added

comment:1 Changed 6 years ago by akks

Description: modified (diff)

comment:2 Changed 6 years ago by Balaitous

I think I have found the bug, I will fix it quickly.

comment:3 Changed 6 years ago by drnoble

Just a quick note to say I am also experiencing this since upgrading to release 7000 on Mac OS X 10.9.2

thanks in advance for any progress in fixing this one

comment:4 Changed 6 years ago by Don-vip

Ticket #9963 has been marked as a duplicate of this ticket.

comment:5 Changed 6 years ago by anonymous

Ticket #9971 has been marked as a duplicate of this ticket.

comment:6 Changed 6 years ago by Balaitous

Resolution: fixed
Status: newclosed

In 7052/josm:

fix #9951 - "Join Overlapping Areas" gives strange multipolygons

comment:7 Changed 6 years ago by Balaitous

This algorithm is complex. I hope that this time it is good!

comment:8 Changed 6 years ago by bastiK

Yes, was a long process to get there, see #5179 for some difficult cases.

comment:9 Changed 6 years ago by Don-vip

it could be a good idea to add non-regression unit tests for this feature, as it looks complicated.

comment:10 Changed 6 years ago by Balaitous

Yes, I have tried after #7959, but I haven't be able to create necessary mock objects.

comment:11 Changed 6 years ago by Don-vip

Ticket #9982 has been marked as a duplicate of this ticket.

comment:12 Changed 6 years ago by Don-vip

Ticket #10268 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.