Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9936 closed defect (duplicate)

Unexpectd Error in Pic Layer Plugin

Reported by: TomaszStelmach Owned by: TomaszStelmach
Priority: critical Milestone:
Component: Plugin piclayer Version: tested
Keywords: Plugin Piclayer Cc: TomaszStelmach

Description

What steps will reproduce the problem?

  1. Open JOSM
  2. Enable and Update PicLayer Plugin
  3. Enable Building Plugin
  4. Click Imagery and upload an image (enable the image view and move selected image up)
  5. Start move, rotate, zoom the image

What is the expected result?
Should be no error pop up.

What happens instead?
Unexpected error occurs, the error message is regarding to Pic Layer Plugin.
I have tried update, uninstall and reinstall josm, pic layer, still able to reproduce.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-03-30 00:22:45
Last Changed Author: Don-vip
Revision: 6950
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-03-30 01:17:23 +0100 (Sun, 30 Mar 2014)
Last Changed Rev: 6950

Identification: JOSM/1.5 (6950 en) Windows 7 64-Bit
Memory Usage: 71 MB / 455 MB (19 MB allocated, but free)
Java version: 1.7.0_51, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Xms16m, -Xmx512m]

Plugin: PicLayer (30375)
Plugin: buildings_tools (30375)
Plugin: turnrestrictions (30375)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.UndoRedoHandler.afterAdd(UndoRedoHandler.java:57)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:66)
	at org.openstreetmap.josm.plugins.piclayer.command.TransformCommand.addIfChanged(TransformCommand.java:87)
	at org.openstreetmap.josm.plugins.piclayer.actions.GenericPicTransformAction.mouseReleased(GenericPicTransformAction.java:92)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7705.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain TomaszStelmach.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.