Modify

Opened 8 years ago

Closed 6 years ago

#7705 closed defect (fixed)

NPE when using piclayer plugin without data layer

Reported by: RafalR Owned by: team
Priority: normal Milestone: 14.04
Component: Core Version: latest
Keywords: Cc: TomaszStelmach

Description

This error occurs when I want to edit a layer:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-05-15 01:31:01
Last Changed Author: simon04
Revision: 5240
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-05-14 15:04:43 +0200 (Mon, 14 May 2012)
Last Changed Rev: 5240

Identification: JOSM/1.5 (5240 pl)
Memory Usage: 989 MB / 989 MB (778 MB allocated, but free)
Java version: 1.6.0_31, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows Vista

Plugin: PicLayer (27883)
Plugin: openstreetbugs (27852)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.UndoRedoHandler.afterAdd(UndoRedoHandler.java:51)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:59)
	at org.openstreetmap.josm.plugins.piclayer.command.TransformCommand.addIfChanged(TransformCommand.java:87)
	at org.openstreetmap.josm.plugins.piclayer.actions.GenericPicTransformAction.mouseReleased(GenericPicTransformAction.java:91)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by Larry0ua

Steps how to reproduce the bug are needed.

Do not see how to reproduce it easily (or that may be introduced in some latest version, and then that is core problem)

comment:2 Changed 6 years ago by skyper

Ticket #9936 has been marked as a duplicate of this ticket.

comment:3 Changed 6 years ago by skyper

Cc: TomaszStelmach added

comment:4 Changed 6 years ago by Don-vip

Component: Plugin piclayerCore
Milestone: 14.04
Owner: changed from Larry0ua to team
Summary: Piclayer event errorNPE when using piclayer plugin without data layer

comment:5 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6994/josm:

fix #7705 - NPE when using piclayer plugin without data layer

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.