Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9937 closed defect (fixed)

Not importing remote data from overpass

Reported by: naoliv Owned by: team
Priority: major Milestone: 14.04
Component: Core remotecontrol Version:
Keywords: Cc: bastiK

Description

I am trying to import this query http://overpass-turbo.eu/s/38q into JOSM (using the export button).
I see that JOSM is receiving it:

INFO: RemoteControl received: GET /version HTTP/1.1
INFO: RemoteControl received: GET /import?url=http%3A%2F%2Foverpass-api.de%2Fapi%2Finterpreter%3Ffixme%3DJOSM-ticket-8566%26data%3D%253C!--%250AThis%2520query%2520looks%2520for%2520nodes%252C%2520ways%2520and%2520relations%2520%250Awith%2520the%2520given%2520key%252Fvalue%2520combination.%250AChoose%2520your%2520region%2520and%2520hit%2520the%2520Run%2520button%2520above!%250A--%253E%250A%250A%250A%253Cosm-script%2520output%253D%2522xml%2522%253E%253C!--%2520fixed%2520by%2520auto%2520repair%2520--%253E%250A%2520%2520%253Cunion%253E%250A%2520%2520%2520%2520%253Cquery%2520type%253D%2522node%2522%253E%250A%2520%2520%2520%2520%2520%2520%253Chas-kv%2520k%253D%2522source%2522%2520v%253D%2522Google%2522%252F%253E%250A%2520%2520%2520%2520%2520%2520%253Cbbox-query%2520s%253D%2522-33.35806161277886%2522%2520w%253D%2522-60.029296875%2522%2520n%253D%2522-1.669685500986571%2522%2520e%253D%2522-21.4453125%2522%252F%253E%250A%2520%2520%2520%2520%253C%252Fquery%253E%250A%2520%2520%2520%2520%253Cquery%2520type%253D%2522way%2522%253E%250A%2520%2520%2520%2520%2520%2520%253Chas-kv%2520k%253D%2522source%2522%2520v%253D%2522Google%2522%252F%253E%250A%2520%2520%2520%2520%2520%2520%253Cbbox-query%2520s%253D%2522-33.35806161277886%2522%2520w%253D%2522-60.029296875%2522%2520n%253D%2522-1.669685500986571%2522%2520e%253D%2522-21.4453125%2522%252F%253E%250A%2520%2520%2520%2520%253C%252Fquery%253E%250A%2520%2520%2520%2520%253Cquery%2520type%253D%2522relation%2522%253E%250A%2520%2520%2520%2520%2520%2520%253Chas-kv%2520k%253D%2522source%2522%2520v%253D%2522Google%2522%252F%253E%250A%2520%2520%2520%2520%2520%2520%253Cbbox-query%2520s%253D%2522-33.35806161277886%2522%2520w%253D%2522-60.029296875%2522%2520n%253D%2522-1.669685500986571%2522%2520e%253D%2522-21.4453125%2522%252F%253E%250A%2520%2520%2520%2520%253C%252Fquery%253E%250A%2520%2520%253C%252Funion%253E%250A%2520%2520%253Cprint%2520mode%253D%2522meta%2522%252F%253E%253C!--%2520fixed%2520by%2520auto%2520repair%2520--%253E%250A%2520%2520%253Crecurse%2520type%253D%2522down%2522%252F%253E%250A%2520%2520%253Cprint%2520mode%253D%2522meta%2522%252F%253E%253C!--%2520fixed%2520by%2520auto%2520repair%2520--%253E%250A%253C%252Fosm-script%253E HTTP/1.1
INFO: GET http://overpass-api.de/api/interpreter?fixme=JOSM-ticket-8566&data=%253C!--%250AThis%2520query%2520looks%2520for%2520nodes%252C%2520ways%2520and%2520relations%2520%250Awith%2520the%2520given%2520key%252Fvalue%2520combination.%250AChoose%2520your%2520region%2520and%2520hit%2520the%2520Run%2520button%2520above!%250A--%253E%250A%250A%250A%253Cosm-script%2520output%253D%2522xml%2522%253E%253C!--%2520fixed%2520by%2520auto%2520repair%2520--%253E%250A%2520%2520%253Cunion%253E%250A%2520%2520%2520%2520%253Cquery%2520type%253D%2522node%2522%253E%250A%2520%2520%2520%2520%2520%2520%253Chas-kv%2520k%253D%2522source%2522%2520v%253D%2522Google%2522%252F%253E%250A%2520%2520%2520%2520%2520%2520%253Cbbox-query%2520s%253D%2522-33.35806161277886%2522%2520w%253D%2522-60.029296875%2522%2520n%253D%2522-1.669685500986571%2522%2520e%253D%2522-21.4453125%2522%252F%253E%250A%2520%2520%2520%2520%253C%252Fquery%253E%250A%2520%2520%2520%2520%253Cquery%2520type%253D%2522way%2522%253E%250A%2520%2520%2520%2520%2520%2520%253Chas-kv%2520k%253D%2522source%2522%2520v%253D%2522Google%2522%252F%253E%250A%2520%2520%2520%2520%2520%2520%253Cbbox-query%2520s%253D%2522-33.35806161277886%2522%2520w%253D%2522-60.029296875%2522%2520n%253D%2522-1.669685500986571%2522%2520e%253D%2522-21.4453125%2522%252F%253E%250A%2520%2520%2520%2520%253C%252Fquery%253E%250A%2520%2520%2520%2520%253Cquery%2520type%253D%2522relation%2522%253E%250A%2520%2520%2520%2520%2520%2520%253Chas-kv%2520k%253D%2522source%2522%2520v%253D%2522Google%2522%252F%253E%250A%2520%2520%2520%2520%2520%2520%253Cbbox-query%2520s%253D%2522-33.35806161277886%2522%2520w%253D%2522-60.029296875%2522%2520n%253D%2522-1.669685500986571%2522%2520e%253D%2522-21.4453125%2522%252F%253E%250A%2520%2520%2520%2520%253C%252Fquery%253E%250A%2520%2520%253C%252Funion%253E%250A%2520%2520%253Cprint%2520mode%253D%2522meta%2522%252F%253E%253C!--%2520fixed%2520by%2520auto%2520repair%2520--%253E%250A%2520%2520%253Crecurse%2520type%253D%2522down%2522%252F%253E%250A%2520%2520%253Cprint%2520mode%253D%2522meta%2522%252F%253E%253C!--%2520fixed%2520by%2520auto%2520repair%2520--%253E%250A%253C%252Fosm-script%253E

But nothing happens then.

JOSM is

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-04-22 01:32:36
Last Changed Author: Don-vip
Revision: 6992
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-04-22 01:06:55 +0200 (Tue, 22 Apr 2014)
Last Changed Rev: 6992

Is there a way that I can test to see if it's indeed a problem in JOSM or if it's in overpass?

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by naoliv

Priority: normalmajor

With tested 6950 it works. A friend said that with 6965 it also works. With the latest one (tested now with 6997) it doesn't work.
The problem seems to be indeed in JOSM.

Something related with the last changes in HTTPS usage, maybe?

comment:2 Changed 8 years ago by akks

Could you try with "remotecontrol.importhandler.fix_url_query"=false?

This can be related to changes from #9906

comment:3 Changed 8 years ago by akks

Yes, it was introduced in r6972 (I asked for this change). Can be temporarily fixed with remotecontrol.importhandler.fix_url_query=false.
I am looking to the code and debugging...

Last edited 8 years ago by akks (previous) (diff)

comment:4 Changed 8 years ago by akks

Resolution: fixed
Status: newclosed

In 6999/josm:

fix #9937: Was not importing data from Overpass by remote control (regression of 6972)

comment:5 Changed 8 years ago by akks

Cc: bastiK added
Resolution: fixed
Status: closedreopened

@team: The fix may be dirty (it just keeps "%" when fixing URL), please have a look.
(at least there is a typo in comment)

Last edited 8 years ago by akks (previous) (diff)

comment:6 Changed 8 years ago by bastiK

I think your fix correct, just forgot the "%" in [6972].

comment:7 Changed 8 years ago by Don-vip

Milestone: 14.04
Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.