Modify

Opened 7 years ago

Last modified 7 months ago

#9929 reopened enhancement

Replace geometry does not use nodes with multiple parents

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Plugin utilsplugin2 Version:
Keywords: replace geometry node multiple parent Cc: naoliv

Description

If you have an existing closed way and add one new node to this way and then replace a single, unconnected node with this way, the only node with id:0 should be replaced. I did try it by placing the two nodes really close but still the node does not get the existing id.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-04-17 01:32:45
Last Changed Author: bastiK
Revision: 6988
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-04-16 12:25:27 +0200 (Wed, 16 Apr 2014)
Last Changed Rev: 6988

Identification: JOSM/1.5 (6988 en) Linux Debian GNU/Linux 7.4 (wheezy)
Memory Usage: 440 MB / 672 MB (71 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u25-2.3.10-1~deb7u1
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (30375)
Plugin: conflation (0.1.6)
Plugin: imagery-xml-bounds (30393)
Plugin: jts (30277)
Plugin: mirrored_download (30375)
Plugin: notes (v0.9.2)
Plugin: photoadjust (30277)
Plugin: reverter (30375)
Plugin: terracer (30375)
Plugin: todo (29154)
Plugin: undelete (30375)
Plugin: utilsplugin2 (30391)
Plugin: wikipedia (30375)

Attachments (1)

josm_9929_sample.osm (3.5 KB) - added by skyper 7 months ago.
example file

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by skyper

Ok, my problem seem that shared nodes with id:0 are never replaced.

Found another ticket with similar problem. (#8396)

comment:2 Changed 4 years ago by naoliv

Cc: naoliv added

comment:3 Changed 3 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8396.

Changed 7 months ago by skyper

Attachment: josm_9929_sample.osm added

example file

comment:4 Changed 7 months ago by skyper

This is not a duplicate of #8396 but similar. This ticket is about shared node with id=0 while #8396 is about nodes with only one parent way.

Please, find attached example file: josm_9929_sample.osm

  1. Search type:node id:0
  2. Select address node number 10 and building surrounding the node
  3. Replace geometry
  4. Search type:node id:0
  5. Search all objects for type:node deleted -id:0

Find a deleted node but there are way child nodes with id=0 though they have more than one parent way.
At least in cases of closed ways I would say it is safe to swap ids with any node with id=0.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-08-04 23:38:35 +0200 (Tue, 04 Aug 2020)
Revision:16850
Build-Date:2020-08-05 01:30:51
URL:https://josm.openstreetmap.de/svn/trunk

Plugins:
+ utilsplugin2 (35487)

comment:5 Changed 7 months ago by skyper

Keywords: node multiple parent added
Resolution: duplicate
Status: closedreopened

comment:6 Changed 7 months ago by skyper

Summary: Replace geometry does not choose/find best replacement candidate for nodesReplace geometry does not use nodes with multiple parents

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to skyper
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.