Modify

Opened 7 years ago

Closed 9 months ago

#9911 closed defect (fixed)

Join areas internal error

Reported by: naoliv Owned by: team
Priority: normal Milestone: 20.02
Component: Core Version:
Keywords: template_report Cc:

Description

Select all the ways of the attached file and then Shift+J to join the areas.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-04-09 01:33:23
Last Changed Author: akks
Revision: 6963
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-04-08 11:45:52 +0200 (Tue, 08 Apr 2014)
Last Changed Rev: 6963

Identification: JOSM/1.5 (6963 pt_BR) Linux Debian GNU/Linux testing (jessie)
Memory Usage: 3038 MB / 5086 MB (883 MB allocated, but free)
Java version: 1.7.0_51, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u51-2.4.6-1
VM arguments: [-Djava.net.useSystemProxies=true, -Dawt.useSystemAAFontSettings=on, -Xms3g, -Xmx5g, -XX:+UseConcMarkSweepGC, -XX:+UseCompressedOops]
Dataset consistency test: No problems found

Plugin: Create_grid_of_ways (30375)
Plugin: OpeningHoursEditor (30375)
Plugin: PicLayer (30375)
Plugin: SimplifyArea (30375)
Plugin: buildings_tools (30375)
Plugin: contourmerge (1010)
Plugin: editgpx (30375)
Plugin: geotools (30349)
Plugin: importvec (30375)
Plugin: jts (30277)
Plugin: log4j (30197)
Plugin: measurement (30375)
Plugin: merge-overlap (30375)
Plugin: opendata (30375)
Plugin: pdfimport (30277)
Plugin: poly (30375)
Plugin: reverter (30375)
Plugin: scripting (30601)
Plugin: todo (29154)
Plugin: turnrestrictions (30375)
Plugin: undelete (30375)
Plugin: utilsplugin2 (30384)

java.lang.RuntimeException: Join areas internal error.
	at org.openstreetmap.josm.actions.JoinAreasAction.findBoundaryPolygons(JoinAreasAction.java:1040)
	at org.openstreetmap.josm.actions.JoinAreasAction.joinAreas(JoinAreasAction.java:489)
	at org.openstreetmap.josm.actions.JoinAreasAction.actionPerformed(JoinAreasAction.java:374)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1662)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2869)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:307)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:263)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2961)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2953)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2832)
	at java.awt.Component.processEvent(Component.java:6282)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1895)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:762)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1027)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:899)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:727)
	at java.awt.Component.dispatchEventImpl(Component.java:4731)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (1)

join.osm.bz2 (206.2 KB) - added by naoliv 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by naoliv

Attachment: join.osm.bz2 added

comment:1 Changed 7 years ago by Balaitous

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7959.
Seems duplicate of #7959

comment:2 Changed 10 months ago by GerdP

I can still reproduce this bug with r15820. Should I reopen #7959 or create a new one?

comment:3 Changed 10 months ago by skyper

As this is no complete duplicate, how about reopening this one, as there is no milestone set.

Additionally, it should be considered what Donvip on #9951 wrote comment 9:

it could be a good idea to add non-regression unit tests for this feature, as it looks complicated.

and collecting all examples from the different tickets for a complete set.

comment:4 Changed 10 months ago by GerdP

I also think that I should add some unit tests before I start to change something. I see so many surprising results ;)

comment:5 Changed 9 months ago by GerdP

Resolution: duplicate
Status: closedreopened

comment:6 Changed 9 months ago by GerdP

Milestone: 20.02

comment:7 Changed 9 months ago by GerdP

Resolution: fixed
Status: reopenedclosed

In 15873/josm:

fix #9911: Join areas internal error

  • Correct detection and deduplication of nodes with same position
  • Add command to remove the detected duplicated nodes if they have no tags and no referrers

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.