Modify

Opened 5 years ago

Last modified 3 years ago

#9886 reopened enhancement

Fetch additional information from Wikidata

Reported by: pigsonthewing Owned by: simon04
Priority: normal Milestone:
Component: Plugin wikipedia Version:
Keywords: Cc:

Description (last modified by simon04)

With a node or way selected, it should be possible

  • to give JOSM the URL (or "Q" ID) of a Wikidata item (→ #9775),
  • to then fetch a range of properties (name, use, architect, dates, owner, url, material, sculptor(for a statue), etc.) from there and bring it back into a dialogue for editing and confirmation.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Don-vip

Component: CorePlugin wikipedia
Owner: changed from team to simon04
Type: defectenhancement

comment:2 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9775.

comment:3 Changed 3 years ago by simon04

Description: modified (diff)
Resolution: duplicate
Status: closedreopened
Summary: Fetch tag data from WikidataFetch additional information from Wikidata

I'll keep this open for reference, but I won't implement the "additional information display" too soon …

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain simon04.
as The resolution will be set.
to The owner will be changed from simon04 to the specified user.
The owner will change to pigsonthewing
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.