Modify

Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#9775 closed enhancement (fixed)

Demystify Wikidata tags

Reported by: Polyglot Owned by: simon04
Priority: normal Milestone:
Component: Plugin wikipedia Version:
Keywords: wikidata Cc: pigsonthewing

Description

http://wiki.openstreetmap.org/wiki/Proposed_features/Wikidata

Proposes a way to link to Wikidata. The most heard complaint is that Q12345 is not very easy to verify. Would it be possible to lookup on Wikidata what it stands for and display that next to it, or even instead of it?

Attachments (1)

overflow.png (6.7 KB) - added by simon04 4 years ago.

Download all attachments as: .zip

Change History (28)

comment:1 Changed 5 years ago by Don-vip

Component: CorePlugin wikipedia
Owner: changed from team to simon04

something for wikipedia plugin.

comment:2 Changed 5 years ago by Don-vip

Ticket #9886 has been marked as a duplicate of this ticket.

comment:3 Changed 4 years ago by pigsonthewing

More info:

If an object already has a Wikidata ID, fetch (via API) and display the Wikidata label (and description?) in the user's preferred language (with fallback to English/ whatever is available?) link to the Wikidata item (e.g. for Q5642705, display "Hall of Memory, Birmingham" and link to https://www.wikidata.org/wiki/Q5642705 )

Also, this should be core (if a user finds a Wikidata ID, it should be explained to them, always).

comment:4 Changed 4 years ago by pigsonthewing

Cc: pigsonthewing added

comment:6 Changed 4 years ago by simon04

In 9149/josm:

see #9775 - Allow plugins to change display of keys/values in properties dialog

comment:7 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

comment:8 Changed 4 years ago by simon04

Improved in [o31861:31862].

comment:9 Changed 4 years ago by pigsonthewing

Thank you for your efforts; however, this is not fixed; nor is it a plugin issue.

When a user - an ordinary user, with no Wikipedia plugin installed - sees the tag "Wikidata:Q15771334", that is meaningless to them. The request is to fetch the human-friendly text label for that item, in the user's preferred language, and display that alongside the tag, for example as "Wikidata:Q15771334 (Odeon, Kingstanding)".

comment:10 Changed 4 years ago by pigsonthewing

Resolution: fixed
Status: closedreopened

comment:11 Changed 4 years ago by pigsonthewing

Component: Plugin wikipediaCore

comment:12 Changed 4 years ago by simon04

You can insist on the integration into JOSM core, but it does not mean that it happens any sooner. ;-)

I think it does not make sense to have feature in core and all other Wikipedia/Wikidata related features (e.g., in the plugin – also wrt. maintaining the code.

Many cool JOSM features started as plugins and eventually have been integrated to core, see source:trunk/src/org/openstreetmap/josm/plugins/PluginHandler.java#L86

comment:13 Changed 4 years ago by Polyglot

Hi Simon,

First of all. Thank you for implementing this! (Now I'm glad I mentioned it in the Hangout :-) )

I have 2 more requests...

For one, it would be nice to be able to click through to go to Wikidata

  1. we also have architect:wikidata, subject:wikidata etc, brand:wikidata

Sorry, there is a third one as well. If more than 1 architect worked on a building or more than 1 person is buried in the same grave, or more than 1 brand is available in a shop/dealership, there can be semicolon separated values.

Are the lookups cached locally?

Best wishes!

Jo

comment:14 Changed 4 years ago by simon04

Ad 1: This is already implemented in osmwiki:JOSM/Plugins/Tag2Link and I wouldn't want to duplicate the code …
Ad 2: Good point, I'll add that.
Ad 3: This is not handled at the moment. It might be challenging to display it properly – let's see …

Caching: Yes. However, the cache is not cleared before closing JOSM …

comment:15 Changed 4 years ago by pigsonthewing

I do not "insist on the integration into JOSM core". I simply point out that any solution that does not integrate into JOSM core does not resolve this issue.

comment:16 in reply to:  14 Changed 4 years ago by simon04

Replying to simon04:

Ad 2: Good point, I'll add that.

Done in [o31866:31867].

comment:17 in reply to:  11 Changed 4 years ago by simon04

Component: CorePlugin wikipedia

Replying to pigsonthewing:
This ticket is for the implementation in the plugin. For the core integration I've created #12266.


To be done from 13 is:

Sorry, there is a third one as well. If more than 1 architect worked on a building or more than 1 person is buried in the same grave, or more than 1 brand is available in a shop/dealership, there can be semicolon separated values.

comment:18 Changed 4 years ago by pigsonthewing

This ticket was raised for core, not plugin.

I note that you say in #12266 that you WONTFIX. That's your prerogative, of course, but unless it is fixed, then the issue for which this ticket was raised is not addressed.

Last edited 4 years ago by pigsonthewing (previous) (diff)

comment:19 Changed 4 years ago by simon04

Please stop spamming the issue tracker – now!

We often split tickets if parts of it cannot be resolved right now in order to keep clear what has to be done (having 20 long comments does not help for this).

This ticket has been assigned to the plugin in 2014-03, i.e., before you started commenting.

comment:20 Changed 4 years ago by Polyglot

@pigsonthewing 21 months ago one of the first things that happened, was that a Don-vip, a core developer, said this would be for the Wikipedia plugin. Plugins sometimes are incorporated into core, but that's what the other ticket is for.
As far as I'm concerned, I'm really glad Simon implemented this now.

@Simon04
So: "Vielen Dank, Simon, wirklich toll von dir!"

How do you feel about showing the labels in a tooltip, when the user hovers over it? Maybe the first one could be shown with ... after it to show there's more, that can't be shown, in the field itself?

Jo

Changed 4 years ago by simon04

Attachment: overflow.png added

comment:21 in reply to:  14 Changed 4 years ago by simon04

Replying to simon04:

Ad 3: This is not handled at the moment. It might be challenging to display it properly – let's see …

Done in [o31915:31916] – semicolon separated Wikidata ids are rendered:


The problem is that Swing does not show any indication that the text in the table is too long (when using HTML).

comment:22 Changed 4 years ago by Polyglot

Hi Simon,

I created a screen cast on Twitch.tv where I'm using the extension to the plugin you created:

http://www.twitch.tv/polyglot_openstreetmap/v/34468080

It works really nicely now for items that appear in the list. I still have a few other suggestions that would make life easier... Not sure if it's OK to piggy back on this ticket, or if it would be better to create several separate tickets.

The first thing, is the ability to perform search (in JOSM data) from an item in the downloaded list, with the name of the WP article or the WD label as a starting point. I guess that would mean an extra button for the WP plugin. This is something I do quite often. Alternatively copy the name to the clipboard, would also help already.

The other thing I find myself doing all the time, is search the web with what's in the name tag of the selected object, but I guess that's Tag2Link territory.

Something I do regularly, but which is quite likely a bit tricky to implement (and there might be licensing issues), is a way to create a Wikidata item based on OSM tags. There is this QuickStatements tool which allows to do this conveniently. The tricky part is 'translating' from tags to properties.
The advantage would be that it becomes possible to add precise coordinates to Wikidata directly and to add the resulting WD item to the OSM object in one go. WRT the licensing issues, this may make sense only for items that are being created, so before uploading them makes them subject to ODBL. (Which is the reason why I find myself going back and forth between JOSM and my browser atm).

Anyway, for the Uganda schools import where this would really save some time, it probably makes more sense to import to Wikidata first, and then do it the way we do it now.

Which brings me to my next point. Is the Wikidata plugin only fetching geotagged WP articles, or does it also propose WD items with coordinates in the current BBOX? Slowly but surely there are more items in WD, than there will ever be in WP, as WD is a lot more inclusive. Getting an article accepted on the various Wikipedias is a lot less trivial, than adding an item on Wikidata.

The last point is, if somebody adds a WP item, would it be possible to add the WD at the same time. If there isn't one yet, it probably makes sense to alert the user of this, so they can add one.

I'll stop the rant before this ticket overflows

Jo

comment:23 Changed 4 years ago by Polyglot

OK, I'm using the plugin some more to add Wikidata and Wikipedia tags. In 'normal' cases all is well, but now I go to Brussels.

It's bilingual, well officially, at least.

My interface language is set to nl, but fr is a lot more common in Brussels.

The problem now is, when the wikipedia tag is already set to fr:..., I don't want to step in and overwrite with nl:...

I'd expect a dialog giving to option to abort, replace, or use wikipedia:nl.

For the Wikidata tag, if it's different to what was already present, the user should also be notified/asked for confirmation before overwriting.

Jo

comment:24 Changed 4 years ago by Polyglot

I'm still mapping wikidata tags in Brussels. I switched to fr this time. The tick box for the Museum of Cocoa and Chocolate doesn't become green, because the wikipedia tag points to en:... even though the item already has the correct Wikidata link set.

It will probably be necessary to validate Wikipedia and Wikidata tags independently from each other. Personally I'm already happy if wikidata is set. Especially for these kinds of multilingual situations, which is where it is most useful, I think. Whether the Wikipedia tag is set and to which language version, is not so important to me, and certainly not worthy of an 'edit war'. Contributors like 'simple goals' though, like getting a green tick box in front of the WP items, and then it does start to matter. But those green tick things are dependent on the language set for the WP links.

Jo

comment:25 in reply to:  22 Changed 3 years ago by simon04

Replying to Polyglot:

It works really nicely now for items that appear in the list. I still have a few other suggestions that would make life easier... Not sure if it's OK to piggy back on this ticket, or if it would be better to create several separate tickets.

Separate tickets a preferred.

The first thing, is the ability to perform search (in JOSM data) from an item in the downloaded list, with the name of the WP article or the WD label as a starting point. I guess that would mean an extra button for the WP plugin. This is something I do quite often. Alternatively copy the name to the clipboard, would also help already.

Just double-click the entry. Then a search is performed.

The other thing I find myself doing all the time, is search the web with what's in the name tag of the selected object, but I guess that's Tag2Link territory.

#12039

Something I do regularly, but which is quite likely a bit tricky to implement (and there might be licensing issues), is a way to create a Wikidata item based on OSM tags. There is this QuickStatements tool which allows to do this conveniently. The tricky part is 'translating' from tags to properties.
The advantage would be that it becomes possible to add precise coordinates to Wikidata directly and to add the resulting WD item to the OSM object in one go. WRT the licensing issues, this may make sense only for items that are being created, so before uploading them makes them subject to ODBL. (Which is the reason why I find myself going back and forth between JOSM and my browser atm).

#13121

Which brings me to my next point. Is the Wikidata plugin only fetching geotagged WP articles, or does it also propose WD items with coordinates in the current BBOX? Slowly but surely there are more items in WD, than there will ever be in WP, as WD is a lot more inclusive. Getting an article accepted on the various Wikipedias is a lot less trivial, than adding an item on Wikidata.

#13122

The last point is, if somebody adds a WP item, would it be possible to add the WD at the same time. If there isn't one yet, it probably makes sense to alert the user of this, so they can add one.

#12284

comment:26 in reply to:  23 Changed 3 years ago by simon04

Resolution: fixed
Status: reopenedclosed

Replying to Polyglot:

The problem now is, when the wikipedia tag is already set to fr:..., I don't want to step in and overwrite with nl:...

I'd expect a dialog giving to option to abort, replace, or use wikipedia:nl.

For the Wikidata tag, if it's different to what was already present, the user should also be notified/asked for confirmation before overwriting.

Confirmation dialogs had been added.


I would like to close this issue since its original feature has been added. Do not hesitate to open new tickets for outstanding issues.

comment:27 Changed 3 years ago by simon04

Ticket #14027 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.