Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9872 closed enhancement (fixed)

Sort "Member of" list naturally

Reported by: pbb Owned by: team
Priority: normal Milestone: 14.05
Component: Core Version:
Keywords: Cc:

Description

The membership list inside the "Tags/Memberships" window is sorted alphabetically. When these memberships are transport routes, this sorting is very unnatural.

For example, the memberships list for a bus stop could contain routes in this order:

  • Route 100
  • Route 3
  • Route 45
  • Route 9

In contrast, routes inside the "Relations" window are sorted naturally! The relations window sorts them like this:

  • Route 3
  • Route 9
  • Route 45
  • Route 100

Could the memberships list also be sorted naturally?

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by skyper

duplicate of #9688 ?

comment:2 in reply to:  1 Changed 6 years ago by pbb

Replying to skyper:

duplicate of #9688 ?

No, not a duplicate of #9688. That one reports the relations window being unsorted, while that one is actually sorted nicely for me. My problem is with the memberships part of the tags/memberships window. That is, it's in another window.

comment:3 Changed 6 years ago by pbb

This bug is not a duplicate of, but related to #9668

comment:4 Changed 6 years ago by simon04

Resolution: fixed
Status: newclosed

In 7113/josm:

fix #9872 - Sort "Member of" list naturally

comment:5 Changed 6 years ago by simon04

Milestone: 14.05

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.