Modify

Opened 6 years ago

Closed 6 weeks ago

#9702 closed defect (irreproducible)

Can not change language when entering tags

Reported by: pl71 Owned by: pl71
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description (last modified by pl71)

When entering tags, for example name tag, default language is English. I change my input language in Windows with Alt+Shift, and can enter the value for the tag in my native language. Interestingly, sometimes, my language can not be switched with Alt+Shift.
Windows (7, 64 bit) changes the language icon in the notification area, but JOSM continue to show English letters. That is valid for all input fields - select file, etc. After restarting of JOSM, the normal working of the application restores. JOSM version 6767.

Attachments (3)

input_language.png (15.5 KB) - added by Don-vip 6 years ago.
input language
JOSM input tag.png (47.6 KB) - added by pl71 6 years ago.
JOSM input tag.png.jpg (60.2 KB) - added by pl71 6 years ago.
Input box options

Download all attachments as: .zip

Change History (21)

comment:1 Changed 6 years ago by stoecker

Owner: changed from team to pl71
Status: newneedinfo

JOSM does not automagically knows that you change the operating system language. Is it that what you complain about? You need to restart josm when in "auto" mode or you change the language in settings in the preferences. There is no on-the-fly language switch in josm.

comment:2 Changed 6 years ago by pl71

Sorry, I will try to explain again.
So, I'm entering a name tag. Key is "name:bg" for name tag in Bulgarian language, or simply "name". Down I have to enter the value as text in Bulgarian. At that point I press Alt+Shift to change the input language from English to Bulgarian in my system as I usually do. Most of the time this works, so I can enter a text such as "име на обекта", but sometimes JOSM sticks to English as input language and nothing can change this, except restart. But as I said above, Windows changes the language icon in the notification area.
I find this as an annoying bug. In Preferences/Look and Feel language is set to 'Bulgarian', but this is not connected with my problem I think.
Hope it was more clearer now.

Last edited 6 years ago by pl71 (previous) (diff)

comment:3 Changed 6 years ago by stoecker

That sounds like a Java bug, nothing we can do about it I fear.

comment:4 Changed 6 years ago by stoecker

BTW: Do you use the most recent Java version, if not you should update.

comment:5 Changed 6 years ago by anonymous

JAVA: Version 7 Update 51
Yes, it looks like connected with JAVA. But happens with older versions of JAVA and JOSM also. Strange, that it occurs randomly and I can not find any pattern.

comment:6 Changed 6 years ago by pl71

Description: modified (diff)

Changed 6 years ago by Don-vip

Attachment: input_language.png added

input language

comment:7 Changed 6 years ago by Don-vip

It may be a JOSM bug, it's the only place where we deal with input language:

input language

Is the option "Use English language ... by default" checked or not ?

Changed 6 years ago by pl71

Attachment: JOSM input tag.png added

Changed 6 years ago by pl71

Attachment: JOSM input tag.png.jpg added

Input box options

comment:8 Changed 6 years ago by pl71

"Use English language ..." was not checked:

Input box options

(None of the three options is checked, but recently added tags are shown?? Is it a new bug??
Now I start JOSM with web start, but in the past I downloaded JOSM and started locally, may be there are some options somewhere left in my hard drive???)

Regarding input language problem: JOSM is started in Windows with input language set as "US", later when needed, I change the input language with Alt+Shift. Sometimes it doesn't work.

Actually this option "Use English ..." is convenient, I will try it.

comment:9 Changed 6 years ago by Don-vip

Ticket #9727 has been marked as a duplicate of this ticket.

comment:10 Changed 6 years ago by anonymous

Ah, I posted 9727, but I didn't realise it affected other languages, not just Korean, and not just Linux.

As I said in that other bug report, some input boxes work properly and will accept typing in whatever language is selected, including mixing characters from Korean and English. For example, the 'Add Node' dialog, and the comment box when uploading new data. If someone could look at these two input boxes and figure out what is different from the tag value input box maybe the bug and solution is clear.

Thank you.

comment:11 Changed 5 years ago by stoecker

Resolution: irreproducible
Status: needinfoclosed

comment:12 Changed 5 years ago by dido

Resolution: irreproducible
Status: closedreopened

comment:13 Changed 5 years ago by dido

Hi,

I fully confirm that this defect is present on all of my systems where I have JOSM installed.
It's quite annoying as I need to change the system locale TWICE every time when I enter a non-latin (Bulgarian) text in a tag's value field.

There is a tip of random behavior - the first several edits after startup appear to be OK but after a while all input starts in Latin charset no matter what is the currently selected input locale. If the current locale is BG and I switch it to EN, the input is again latin until I make a second locale switch. This way I typically need two locale switches in order to get Cyrillic characters in the value field.

'Use English ... by default' is unchecked.

Regards,
Dido.

comment:14 Changed 5 years ago by pl71

Version 8491 is still affected by this bug. Bug is irreproducible. It appears mostly when you try to enter the 'name' tag.

comment:15 Changed 4 years ago by simon04

Summary: Can not change languageCan not change language when entering tags

comment:16 Changed 4 years ago by anonymous

Ticket #12806 has been marked as a duplicate of this ticket.

comment:17 Changed 6 weeks ago by skyper

Can not reproduce with java 11 using German and English as input languages.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-02 22:34:59 +0100 (Thu, 02 Jan 2020)
Revision:15628
Build-Date:2020-01-02 21:52:31
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15628 en) Linux Debian GNU/Linux 10 (buster)
Java version: 11.0.5+10-post-Debian-1deb10u1, Debian, OpenJDK 64-Bit Server VM

comment:18 Changed 6 weeks ago by Don-vip

Resolution: irreproducible
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain pl71.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.