Modify

Opened 4 years ago

Closed 4 years ago

#12806 closed defect (duplicate)

Input language changed after saving tag

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Have more than one input language enabled in Windows 10
  2. Add a tag

What is the expected result?

Input language is not changed without user input through Windows language bar

What happens instead?

The input language is cycled to the next entry without user input given to do so.

Please provide any additional information below. Attach a screenshot if possible.

https://vid.me/18V4
Note the input language changing from ENG to DAN when I save the tag. The situation is the same even if I have ENG or 中 set as input language before opening the tag window.

I have not enable 'remember tag input language' but I have enabled 'save last 5 tags'.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-03-13 01:17:21 +0100 (Sun, 13 Mar 2016)
Build-Date:2016-03-13 02:35:00
Revision:9979
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9979 en) Windows 10 64-Bit
Memory Usage: 210 MB / 989 MB (108 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- PicLayer (31895)
- buildings_tools (31895)
- geochat (31895)
- poly (31772)
- turnrestrictions (31895)
- utilsplugin2 (32099)

Last errors/warnings:
- W: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server

Attachments (1)

2016-04-29_19-36-50.mp4 (425.3 KB) - added by anonymous 4 years ago.

Download all attachments as: .zip

Change History (2)

comment:1 Changed 4 years ago by anonymous

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9702.

Changed 4 years ago by anonymous

Attachment: 2016-04-29_19-36-50.mp4 added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.