Modify

Opened 6 years ago

Closed 6 years ago

#9727 closed defect (duplicate)

Support for entering Korean text with Linux (ibus)

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

I am doing a lot of mapping in Korea. I used to be able to enter Korean text easily by switching between English and Korean text. This was with an older version of Linux, and using 'nabi' for Korean input (hangul).

Now I am using a later Linux and using 'ibus' for Korean input. All of my KDE apps, and Firefox and LibreOffice etc. will allow me to type English or Korean and I can switch easily between them. However, I have difficulty doing this with JOSM. Obviously, a lot has changed between the old version of Linux and the new one, so I am not sure where the problem lies. Is it JOSM, java, KDE, or ibus?

I *can* type Korean into *some* dialogs in JOSM. For example, "add node". Instead of typing a lat/lon I can type a string of Korean characters and switch back and forth between English and Korean. I can cut and paste this into the tags of an object, but it's very tedious.

When I am editing tags, if I try to enter Korean text into a value field then I get various results. Sometimes (actually it's rare) I can enter Korean characters into the 'value' text box. Sometimes I can enter the first letter but then input switches to English. Sometimes I only get English, despite the current setting of the input mode.

There is no problem pasting Korean text from elsewhere into the 'value' text box, or selecting other Korean values that are in the drop-down list.

I *can* enter text easily into the changeset comments dialog, and switch between Korean and English.

As I said, I don't know where the problem lies, but parts of JOSM do the right thing and parts don't. If someone could look into the difference between the tag entry dialog and the changeset comment entry dialog perhaps there is something that jumps out as obviously different?

I could also go back to an older version of JOSM to try. Please advise what I can do to help.

Thank you.

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9702.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.