Modify

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#9624 closed defect (fixed)

[Patch] wrong order of deleted relations at upload

Reported by: malenki Owned by: team
Priority: normal Milestone: 14.02
Component: Core Version:
Keywords: Cc:

Description

Problem
JOSM doesn't create a sensible order at upload of relations to be deleted.

How users are affected
When cleaning up relations by deleting nested relations.
Example: deleting all three: a relation C that contains a relation B that contains a relation A
JOSM does order arrange the order of to-be-deleted relations by alphabet.
This is a problem since now JOSM uploads deleted relation A first but assumes/gets told by the server relation B and C are still existing so returns with
<Precondition failed: The relation $number_of_A is used in relation $number_of_B.>

Attachments (2)

9624.patch (4.7 KB) - added by simon04 6 years ago.
9624_v2.patch (4.8 KB) - added by simon04 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by simon04

In my opinion, the OSM API (project at https://github.com/openstreetmap/openstreetmap-website) should take care of this situation.

comment:2 Changed 6 years ago by malenki

Reported it there - and it got "solved" quite speedily: https://github.com/openstreetmap/openstreetmap-website/issues/688

Changed 6 years ago by simon04

Attachment: 9624.patch added

comment:3 Changed 6 years ago by simon04

Milestone: 14.02
Summary: wrong order of deleted relations at upload[Patch] wrong order of deleted relations at upload

We fix JOSM's upload ordering – patch attached.

Changed 6 years ago by simon04

Attachment: 9624_v2.patch added

comment:4 Changed 6 years ago by Don-vip

Is it not a duplicate of #7157 ? And maybe we should address #6373 as well at the same time.

comment:5 Changed 6 years ago by simon04

Ticket #7157 has been marked as a duplicate of this ticket.

comment:6 Changed 6 years ago by simon04

Resolution: fixed
Status: newclosed

In 6776/josm:

fix #9624 - Create a sensible upload order of relations to be deleted

This fixes "Precondition failed: The relation X is used in relation Y" when X and Y are to be deleted

comment:7 Changed 5 years ago by Don-vip

Ticket #8139 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.