Modify

Opened 5 years ago

Last modified 16 months ago

#9270 reopened enhancement

Show icons on map also for areas and lines, not only for nodes

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Internal mappaint style Version:
Keywords: Cc: skyper, Klumbumbus

Description

It would make tags accessible without clicking on objects.

Current display encourages duplication - saving information both as area and node and/or discourages tagging things like parkings, theaters, shops as areas.

And it is nearly impossible to notice untagged or unproperly tagged area among multiple others, I am not going to click every single one.

In other words I would prefer here googlelike style: https://maps.google.com/?ll=50.069474,19.932726&spn=0.00089,0.002642&t=m&z=19 - note that hospital is marked both as area and by icon.

Attachments (0)

Change History (14)

comment:1 Changed 5 years ago by Don-vip

Component: Core imageryCore mappaint

comment:2 Changed 5 years ago by mkoniecz

example: http://www.openstreetmap.org/browse/way/118717694

It would preferably to see not it as blue building, but as blue building with icon of car_repair shop (like it would happen in case of duplicate tagging - as area and as node)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-11-09 02:35:12
Last Changed Author: Don-vip
Revision: 6381
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-11-08 14:41:01 +0100 (Fri, 08 Nov 2013)
Last Changed Rev: 6381

Identification: JOSM/1.5 (6381 en_GB) Windows 7 32-Bit
Memory Usage: 247 MB / 247 MB (44 MB allocated, but free)
Java version: 1.7.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (29854)
Plugin: notes (v0.6)

comment:3 Changed 4 years ago by bastiK

Ticket #10176 has been marked as a duplicate of this ticket.

comment:4 Changed 4 years ago by mkoniecz

Component: Core mappaintInternal mappaint style

comment:5 Changed 4 years ago by skyper

Cc: skyper added

comment:6 Changed 4 years ago by mkoniecz

To clarify - this ticket is about doing this in default map style, #10176 is about making icon on area possible to display using JOSM mappaint (what may or may not be used in default style).

comment:7 Changed 4 years ago by bastiK

Resolution: invalid
Status: newclosed

This feature is not supported at the moment, so it cannot be used in the default style. Please reopen when #10176 is fixed.

comment:8 Changed 16 months ago by michael2402

Resolution: invalid
Status: closedreopened

This is now implemented based on #10176, see [11670]. Feel free to experiment ;-)

Feel free to provide feedback. Especially on how to give users feedback on the difference between an area icon (not selectable) and a node icon (selectable).

comment:9 Changed 16 months ago by stoecker

Making area icons selectable would be fine BTW. That could also solve the issue, that e.g. turn-restriction icons aren't selectable. My idea in the past for these was to have a cache containing positions of currently displayed non-clickable icons and the related objects.

comment:10 Changed 16 months ago by Klumbumbus

Cc: Klumbumbus added

comment:11 Changed 16 months ago by Klumbumbus

It would be great to use this feature in the default style. However first the display of text together with icon must be fixed (considering also external mappaint styles, which e.g. adjust the size of the text, like Coloured Streets). currently icon and overlap each other.

comment:12 Changed 16 months ago by Klumbumbus

Another problem I see is that e.g. an landuse area can be very large or you are zoomed in far and you see an icon and have no clue where it belongs to. So maybe the icon should be hidden if more than 25% (?) of the area is outside the visible mapview. Maybe we can find a better rule.

comment:13 in reply to:  12 Changed 16 months ago by bastiK

Replying to Klumbumbus:

Another problem I see is that e.g. an landuse area can be very large or you are zoomed in far and you see an icon and have no clue where it belongs to. So maybe the icon should be hidden if more than 25% (?) of the area is outside the visible mapview. Maybe we can find a better rule.

We could start with areas that can also be mapped as a point, like restaurant and school. These are smaller and less problematic. Another idea would be to highlight the area when you hover the mouse over the area icon.

comment:14 Changed 16 months ago by michael2402

We have the same problem with the label. Currently, we simply display it every time.

I don't think that we should hardcode this into josm. It would be best to allow for some sort of pseudo selector that allows to select elements that are bigger than x. We could then use this to

The problem I see is that our MapCSS implementation does not have such a feature at the moment. If we add it, we should also be prepared to add :hover / :active. This will require some work on the style computation side.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to mkoniecz
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.