Modify

Opened 6 years ago

Closed 6 years ago

#9043 closed enhancement (fixed)

Verify links on highways

Reported by: erickdeoliveiraleal Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: link highway check Cc: aceman

Description

For example if we have a roundabout with a highway tag that differs from the highways which the roundabout is connected we have an error on JOSM, why links like "secondary_link" which is connected to 2 tertiary highways doesn't give an error to JOSM?

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by Don-vip

Keywords: highway roundabout added; validator removed
Priority: majornormal

comment:2 Changed 6 years ago by skyper

Keywords: check added; roundabout removed

comment:3 Changed 6 years ago by skyper

Ticket #9305 has been marked as a duplicate of this ticket.

comment:4 Changed 6 years ago by skyper

Cc: aceman added

comment:5 Changed 6 years ago by aceman

OK, this is a dupe, but I hope the developers will know what is actually requested here (what to check) :) If not, there is a better specification in ticket #9305.

comment:6 in reply to:  5 Changed 6 years ago by skyper

Replying to aceman:

OK, this is a dupe, but I hope the developers will know what is actually requested here (what to check) :) If not, there is a better specification in ticket #9305.

A secondary_link only connected to tertiary should be changed to tertiary_link, do you not agree ?

comment:7 Changed 6 years ago by aceman

Yes, if it is connected only to a tertiary (or anything else) then it should be flagged. However if on the other end it is connected to secondary_link or secondary, then it is fine.

comment:8 Changed 6 years ago by simon04

Resolution: fixed
Status: newclosed

In 6573/josm:

fix #9043 - Validator: Verify links on highways

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.