Modify

Opened 8 years ago

Closed 8 years ago

#9044 closed defect (duplicate)

Null pointer exception whilst attempting to revert a changeset

Reported by: SomeoneElse Owned by: Upliner
Priority: normal Milestone:
Component: Plugin reverter Version:
Keywords: reverted exception Cc:

Description

I attempted to revert
http://www.openstreetmap.org/browse/changeset/17650342

Info as follows:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-08-07 01:35:24
Last Changed Author: Don-vip
Revision: 6115
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-08-07 00:04:24 +0200 (Wed, 07 Aug 2013)
Last Changed Rev: 6115

Identification: JOSM/1.5 (6115 en_GB) Windows 7 64-Bit
Memory Usage: 64 MB / 247 MB (29 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, Java HotSpot(TM) Client VM

Dataset consistency test:
[WARN - ZERO NODES] Way {Way id=169500356 version=2 MT nodes=[]} has zero nodes
[WARN - ZERO NODES] Way {Way id=169498491 version=2 MT nodes=[]} has zero nodes
[WARN - ZERO NODES] Way {Way id=198653479 version=2 MT nodes=[]} has zero nodes
[WARN - NO NODES] Way {Way id=195163073 version=2 MT nodes=[{Node id=2056481035 version=2 VT lat=40.6995849,lon=8.5993086}]} has only one node
[WARN - NO NODES] Way {Way id=198653475 version=2 MT> nodes=[{Node id=769024428 version=2 V lat=40.6987525,lon=8.5930507}]} has only one node
[WARN - ZERO NODES] Way {Way id=169501656 version=2 MT nodes=[]} has zero nodes
[WARN - NO NODES] Way {Way id=168638780 version=2 MT nodes=[{Node id=1798639548 version=1 V lat=40.6749791,lon=8.612288}]} has only one node
[WARN - NO NODES] Way {Way id=198653476 version=2 MT> nodes=[{Node id=769024468 version=2 V lat=40.6986383,lon=8.593034}]} has only one node
[WARN - ZERO NODES] Way {Way id=169500327 version=2 MT nodes=[]} has zero nodes
[WARN - ZERO NODES] Way {Way id=219403642 version=2 MT nodes=[]} has zero nodes
[WARN - NO NODES] Way {Way id=195163100 version=2 MT nodes=[{Node id=769024307 version=1 V lat=40.6976723,lon=8.5955687}]} has only one node
[WARN - NO NODES] Way {Way id=168638908 version=2 MT nodes=[{Node id=306814117 version=2 V lat=40.6914273,lon=8.5521053}]} has only one node
[WARN - NO NODES] Way {Way id=195163113 version=2 MT nodes=[{Node id=769024487 version=2 V lat=40.6978941,lon=8.5956989}]} has only one node
[WARN - NO NODES] Way {Way id=168638825 version=2 MT nodes=[{Node id=1798643104 version=1 V lat=40.7147933,lon=8.6111455}]} has only one node
[WARN - ZERO NODES] Way {Way id=219403643 version=2 MT nodes=[]} has zero nodes

Plugin: continuosDownload (28565)
Plugin: reverter (29771)

java.lang.NullPointerException

at org.openstreetmap.josm.data.validation.tests.WayConnectedToArea.visit(WayConnectedToArea.java:31)
at org.openstreetmap.josm.data.osm.Way.accept(Way.java:212)
at org.openstreetmap.josm.data.validation.Test.visit(Test.java:144)
at org.openstreetmap.josm.actions.upload.ValidateUploadHook.checkUpload(ValidateUploadHook.java:61)
at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:197)
at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:220)
at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:270)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$200(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue$4.run(Unknown Source)
at java.awt.EventQueue$4.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9045.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.