Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9028 closed defect (fixed)

josm hangs for ~10s when trying to open the "Imagery" menu

Reported by: anonymous Owned by: team
Priority: normal Milestone: 14.01
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Start josm
  2. Open the "Imagery" menu

What is the expected result?

Menu opens immediately.

What happens instead?

Menu opens after 10 seconds.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-08-29 01:35:07
Last Changed Author: Don-vip
Revision: 6207
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-08-29 01:04:44 +0200 (Thu, 29 Aug 2013)
Last Changed Rev: 6207

Identification: JOSM/1.5 (6207 en) Windows Vista 32-Bit
Memory Usage: 52 MB / 247 MB (27 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, Java HotSpot(TM) Client VM

I've also tested with -tested and tried to disable all plugins.

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by Don-vip

Owner: changed from team to anonymous
Status: newneedinfo

I have never seen this. Do you edit in a particular area ? Have you tried on another machine ? What's your hardware ?

comment:2 Changed 6 years ago by david@…

It's a new behaviour for me too. I'm editing in Austria. The H/W is an aging but well working Dell Latitude E5500 running Vista with 3GB RAM.

It might be that the flaky network here is a cause? Sometimes DNS requests time out. The 10s might match such a timeout, but the stalls were too regular and always while testing, even though downloading the JOSM versions and the Changelogs on the start screen worked.

comment:3 Changed 6 years ago by bastiK

The imagery menu is dynamic, i.e. the known entries for the current map location are selected. It sounds as if there is a network request before the menu is shown. This would be a bug, only offline data is supposed to be used to avoid exactly these problems.

comment:4 Changed 6 years ago by david@…

That sounds plausible. Anything else you need to know?

comment:5 Changed 6 years ago by bastiK

In case you know how to use tools like wireshark, it would certainly help to know what kind of network request is made (if any).

comment:6 Changed 6 years ago by simon04

It might be related to #6797 (some imagery entries specify an URL to an icon).

comment:7 Changed 6 years ago by Don-vip

Milestone: 14.01
Owner: changed from anonymous to team
Status: needinfonew

comment:8 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6707/josm:

fix #9028, see #6797 - load imagery layer icons in background

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.