Modify

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#8995 closed defect (fixed)

[patch] do not let emergency=* trigger the "road restrictions" preset

Reported by: aceman Owned by: team
Priority: minor Milestone:
Component: Internal preset Version: tested
Keywords: Cc:

Description

Having a simple object with the emergency=fire_hydrant offers the "Edit fire hydrant" preset dialog, but also the "Edit road restriction". Probably the latter one is matched by emergency=*. Maybe making emergency=fire_hydrant rule more specific will overrule the road restriction one.

http://wiki.openstreetmap.org/wiki/Tag:emergency%3Dfire_hydrant

Attachments (1)

8995-RoadRestrictionEmergency.diff (1.2 KB) - added by AlfonZ 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by Don-vip

Summary: do not let emergency=fire_hydrant trigger the "road restrictions" presetdo not let emergency=* trigger the "road restrictions" preset

Not specific to fire_hydrant, same with emergency=aed

comment:2 Changed 6 years ago by aceman

The problem is that there are some values e.g. emergency=yes that JOSM uses to describe access for emergency vehicles.

The wiki on this is strange:
http://wiki.openstreetmap.org/wiki/Key:emergency says access= is to be used for the access restrictions, but http://wiki.openstreetmap.org/wiki/Key:access is not clear on this. There is emergency=* described. Should that be read as access:emergency=* ? It seems the discussion on the page is unclear.

So the solution in JOSM seems to be to pick only some specific values of emergency= to be matched by the road restriction preset and all other values to be matched by the some "emergency equipment" presets, e.g. hydrant.

Changed 6 years ago by AlfonZ

comment:3 Changed 6 years ago by AlfonZ

JOSM displays all presets that match currently selected object(s). There is no mechanism for making one preset "superior" to others and there shouldn't be.

What is possible though, is to make Road restriction's matching narrower - 8995-RoadRestrictionEmergency.diff.
The downside is, that setting different value to emergency key in Road restriction can lead to not displaying it.
This can be currently seen for example in Building preset.
Apply Building to an object, set building to yes, preset will be shown in the properties.
Apply Building to an object, set building to test, preset will not be shown in the properties.

As the list of values for emergency key (access-wise) is not that dynamic, I think this changed behaviour is acceptable.

comment:4 Changed 6 years ago by aceman

Sorry, I was probably thinking of the mappaint-style file, where priority for rules can be set.

If the patch makes the "road restrictions" preset to match only when emergency is one of yes,official,designated,destination,permissive,private,no then that is what I wanted. Thanks.

comment:5 Changed 6 years ago by Don-vip

Summary: do not let emergency=* trigger the "road restrictions" preset[patch] do not let emergency=* trigger the "road restrictions" preset

According to taginfo, more than 75% of emergency tags do not match road restrictions, so we'll take your patch :)

comment:6 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6179/josm:

fix #8995 - restrict matching of emergency tag to specified values in road restriction preset

comment:7 Changed 6 years ago by aceman

Looks fine to me, thanks.

comment:8 in reply to:  7 Changed 6 years ago by Don-vip

Replying to aceman:

Looks fine to me, thanks.

Welcome :) However, it's ok to not say thanks on all your tickets (especially 10 days after), because I received a lot of e-mails today :)

comment:9 Changed 5 years ago by Don-vip

In 7613/josm:

see #8995, fix #10630 - change keyvalue match meaning to "neutral otherwise", add new keyvalue! match mode by default with the old meaning (negative otherwise)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.