Modify

Opened 8 years ago

Closed 8 years ago

#8960 closed defect (duplicate)

"DataIntegrityProblemException: Primitive must be part of the dataset" when reloading/updating OpenStreetBugs list

Reported by: openstreetmap@… Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description (last modified by skyper)

I clicked on the 'reload' button for the list of OpenStreetBugs and got this error message.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-08-07 01:35:24
Last Changed Author: Don-vip
Revision: 6115
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-08-07 00:04:24 +0200 (Wed, 07 Aug 2013)
Last Changed Rev: 6115

Identification: JOSM/1.5 (6115 de) Windows XP 32-Bit
Memory Usage: 206 MB / 494 MB (67 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Xms16m, -Xmx512m]
Dataset consistency test: No problems found

Plugin: dataimport (29435)
Plugin: mapdust (29525)
Plugin: measurement (29750)
Plugin: merge-overlap (29778)
Plugin: mirrored_download (29753)
Plugin: openstreetbugs (29435)
Plugin: turnrestrictions (29435)

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=746457 version=1 VT lat=51.054331,lon=13.152493}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:333)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:947)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:968)
	at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog.selectionChanged(PropertiesDialog.java:632)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.fireEvents(SelectionEventManager.java:79)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.access$200(SelectionEventManager.java:20)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager$1.run(SelectionEventManager.java:87)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by skyper

Description: modified (diff)
Version: tested

One more duplicate of #7170 ?

comment:2 Changed 8 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #5783.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.