Modify

Opened 7 years ago

Closed 7 years ago

#8679 closed defect (fixed)

Reverting a changeset removes unmodified tags

Reported by: Cobra Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

When reverting a changeset, the reverter plugin removes tags from some nodes.

  1. open josm
  2. revert changeset 15875373, downloading needed data, zoom to data (ignore conflicts)
  3. undo, watch data, see some traffic lights and crossing symbols appear
  4. Select one of these nodes, watch its tags
  5. redo, then undo again and notice that all tags are being removed
  6. Look at the history, e.g. http://osm.mapki.com/history/node.php?id=480761975 and see that this node's tags shouldn't be touched by this revert.

Again, this is severly damaging data and might be quite difficult to notice.

Might be related to #8676.

Build-Date: 2013-05-06 11:49:36
Revision: 5932
Is-Local-Build: true

Identification: JOSM/1.5 (5932 SVN en) Linux Ubuntu 11.04
Memory Usage: 221 MB / 3640 MB (86 MB allocated, but free)
Java version: 1.7.0_21, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Xmx4G, -Dsun.java2d.opengl=false]
Dataset consistency test: No problems found

*snip*
Plugin: reverter (29561)
*snap*

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by Cobra

Also related: #8680, an issue with the history dialog uncovered when looking at this bug.

comment:2 Changed 7 years ago by Don-vip

Component: Plugin reverterCore
Owner: changed from Upliner to team

core problem caused by r5919.

comment:3 Changed 7 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 5935/josm:

fix #8679, fix #8680 - correct handling of incomplete nodes without coordinates (for good)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.