Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8656 closed defect (invalid)

JOSM doesn't start

Reported by: bjoern_m Owned by: team
Priority: major Milestone:
Component: Applet Version:
Keywords: Cc:

Description

After running "josm", there is the Message "Hauptfenster erstellen" (->creating main window) and after some seconds it appears a message window "An unexpected exception occurred. Please consider being kind and file a bug report..." JOSM remains in the state of "Hauptfenster erstellen".

Debian-Release: 0.0.svn4064-3
Build-Date: 2011-06-16 23:17:11
Revision: 4064
Is-Local-Build: true

Identification: JOSM/1.5 (4064 de)
Memory Usage: 55 MB / 592 MB (24 MB allocated, but free)
Java version: 1.6.0_27, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux

java.lang.IllegalArgumentException: can't parse argument number: width

at java.text.MessageFormat.makeFormat(MessageFormat.java:1356)
at java.text.MessageFormat.applyPattern(MessageFormat.java:475)
at java.text.MessageFormat.<init>(MessageFormat.java:367)
at java.text.MessageFormat.format(MessageFormat.java:828)
at org.openstreetmap.josm.tools.I18n.tr(I18n.java:141)
at org.openstreetmap.josm.data.imagery.ImageryLayerInfo.loadDefaults(ImageryLayerInfo.java:76)
at org.openstreetmap.josm.gui.preferences.ImageryPreference.initialize(ImageryPreference.java:839)
at org.openstreetmap.josm.Main.<init>(Main.java:238)
at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:59)
at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:231)

Attachments (0)

Change History (3)

comment:1 in reply to:  description Changed 8 years ago by skyper

Replying to bjoern.mahrt (at) gmx.de:

Tanks for your report

Debian-Release: 0.0.svn4064-3

Please, update your system.

I do not know from which server you got your debian package from but this version did not enter squeeze and there are no backports. Considering wheezy/sid your packages are quite outdated.

Anyway, for reporting bugs in debian packages please use the Debian bug tracker:

reportbug josm

Thanks.

comment:2 Changed 8 years ago by Don-vip

Resolution: invalid
Status: newclosed

Your version is two years old, please update it.

comment:3 Changed 8 years ago by stoecker

Ticket #8819 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.