Modify

Opened 9 years ago

Closed 8 years ago

Last modified 3 years ago

#8517 closed enhancement (fixed)

Validation results are unsorted

Reported by: windu.2b Owned by: team
Priority: minor Milestone: 13.12
Component: Core validator Version: latest
Keywords: Cc:

Description (last modified by Don-vip)

The validation windows displays unsorted elements, which it's not always easy to read:

unsorted elements ('empty role found')

Attachments (2)

unsorted_validation_results.png (9.2 KB) - added by windu.2b 9 years ago.
unsorted elements ('empty role found')
sortValidatorDialog.patch (10.3 KB) - added by windu.2b 9 years ago.
sort validator dialog

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by windu.2b

unsorted elements ('empty role found')

Changed 9 years ago by windu.2b

Attachment: sortValidatorDialog.patch added

sort validator dialog

comment:1 Changed 9 years ago by windu.2b

see the patch

comment:2 Changed 9 years ago by Don-vip

Description: modified (diff)
Summary: Validation results are unsorted[Patch] Validation results are unsorted

comment:3 Changed 9 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 5783/josm:

fix #8517 - Sort validator results (based on patch by windu.2b)

comment:4 Changed 9 years ago by Don-vip

Resolution: fixed
Status: closedreopened
Summary: [Patch] Validation results are unsortedValidation results are unsorted
Type: defectenhancement

The patch does not work. TreeSet cannot be used in MultiMap because it does not respect the general contract of Set (see Javadoc). I have reverted this change in r5822 as it caused a major bug (see #8546).

Last edited 9 years ago by Don-vip (previous) (diff)

comment:5 Changed 8 years ago by naoliv

Ticket #9415 has been marked as a duplicate of this ticket.

comment:6 Changed 8 years ago by simon04

Resolution: fixed
Status: reopenedclosed

In 6468/josm:

fix #8517 - sort validation results

This is accomplished by sorting the error list before constructing the tree.

comment:7 Changed 8 years ago by Don-vip

Milestone: 13.12 (6502)

comment:8 Changed 4 years ago by stoecker

Milestone: 13.12 (6502)13.12

Milestone renamed

comment:9 Changed 3 years ago by GerdP

In 14973/josm:

simplify code, improve performance: Remove obsolete method sortErrors()

The sorting was introduced to fix #8517 but is no longer needed since errors are reordered in OsmValidator.getErrorsBySeverityMessageDescription() when the tree is created. The obsolete sort takes much longer and doesn't improve anything.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.