Modify

Opened 7 years ago

Closed 7 years ago

#8546 closed defect (fixed)

Validator detecting only one of multible "crossing buildings" or "building inside building"

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Core validator Version: latest
Keywords: Cc:

Description

Draw for example 4 overlapping buildings.
Select all - shift-f
Results: Warnings -> Crossing Buildings (1)

tested with version: 5802 but also seen with earlier versions (5899)

Version 5759 shows all "Crossing Buildings" ... as expected.

Attachments (2)

building_cross_valid_bug.osm (4.9 KB) - added by anonymous 7 years ago.
Snapshot_josm.png (51.8 KB) - added by anonymous 7 years ago.
Snapshot: Josm validator

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by Don-vip

Owner: changed from team to anonymous
Status: newneedinfo

Please attach a test file.

Changed 7 years ago by anonymous

Changed 7 years ago by anonymous

Attachment: Snapshot_josm.png added

Snapshot: Josm validator

comment:2 Changed 7 years ago by anonymous

Status: needinfonew

comment:3 Changed 7 years ago by anonymous

Owner: changed from anonymous to team

comment:4 Changed 7 years ago by Don-vip

Priority: normalmajor

Confirmed. Regression introduced between r5779 and r5787 (maybe r5783).

comment:5 Changed 7 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 5822/josm:

fix #8546 - Validator do not detect errors named identically (partial revert of r5783, reopens #8517). This is due to TreeMap that uses compareTo() instead of equals() (see Javadoc)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.