Modify

Opened 9 years ago

Closed 8 months ago

Last modified 7 months ago

#8472 closed enhancement (fixed)

Wikimedia Commons geocoded media support

Reported by: Don-vip Owned by: simon04
Priority: major Milestone: 21.05
Component: Core image mapping Version:
Keywords: wiwosm wikimedia commons media pictures geocoding gsoc-candidate Cc:

Description

It would be nice if wikipedia plugin could allow us to fetch geocoded media from Wikimedia Commons and display them inside JOSM.

I see two ways to get the relevant information:

  1. spatial request
  2. from linked Commons category in the Wikipedia article of an OSM object, referenced by one of the following templates:

Attachments (0)

Change History (16)

comment:1 Changed 9 years ago by simon04

  1. So the idea would be to obtain (geocoded) images from Commons and display them like local geocoded images on the map?
  2. Right now, I cannot think of a use case. When tagging countries/rivers/churches, how would the associated, numerous images help?

comment:2 Changed 9 years ago by Don-vip

  1. Maybe something a little more sophisticated because there will be often several images at the very same location. The Wikimedia Loves monuments Android application had a good approach for that, by displaying dynamic big circles containing the number of pictures in these circles.
  2. It would be useful in urban environment. It can help to map things we don't see on imagery, like the number of levels for a building, very little details that can be hidden by trees (crossings, bumps, street signs, etc.). If you map or check a certain area, you could check for pictures of nearby objects for that.

comment:3 in reply to:  2 Changed 9 years ago by Don-vip

Replying to Don-vip:

something a little more sophisticated because there will be often several images at the very same location. The Wikimedia Loves monuments Android application had a good approach for that, by displaying dynamic big circles containing the number of pictures in these circles.

Maybe this could be a core improvement, if several georeferenced pictures have to be displayed at the same location ?

comment:4 Changed 9 years ago by skyper

Would be a nice feature, especially, if you would see the direction the picture was taken.

comment:5 Changed 5 years ago by bastiK

Ticket #14173 has been marked as a duplicate of this ticket.

comment:6 Changed 5 years ago by hjart

I regularly link images from Commons with OSM objects, either directly via a image=File:* tag or indirectly via Wikidata. The ability to query Commons from within JOSM would often make it way easier for me to find the images I want.

comment:7 Changed 3 years ago by michael2402

Keywords: gsoc-candidate added

comment:8 Changed 2 years ago by pangoSE

This would be fantastic!

comment:9 Changed 9 months ago by simon04

Ticket #18589 has been marked as a duplicate of this ticket.

comment:10 Changed 9 months ago by simon04

Component: Plugin wikipediaCore image mapping
Milestone: 21.05
Status: newassigned

comment:11 Changed 9 months ago by simon04

In 17880/josm:

see #8472 - Show geocoded images from Wikimedia Commons as GeoImageLayer

The icon wikimedia_commons.svg is taken from https://commons.wikimedia.org/wiki/File:Commons-logo.svg ("This image of simple geometry is ineligible for copyright and therefore in the public domain, because it consists entirely of information that is common property and contains no original authorship.")

comment:12 Changed 9 months ago by simon04

In 17883/josm:

see #8472 - Fix build by removing @org.jetbrains.annotations.NotNull

comment:13 Changed 9 months ago by Don-vip

Wow, awesome Simon! :)

comment:14 Changed 9 months ago by pangoSE

This looks very promising. I very much look forward to testing this @simon04

comment:15 Changed 8 months ago by simon04

Resolution: fixed
Status: assignedclosed

comment:16 Changed 7 months ago by Don-vip

In 18021/josm:

see #8472 - don't load image from Wikimedia Commons for real in unit test. Breaks our CI in case of network/load issues, see https://github.com/openstreetmap/josm/runs/3069693523

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.