Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8235 closed defect (duplicate)

OperationalError: database is locked

Reported by: skyper Owned by: stoecker
Priority: normal Milestone:
Component: Trac Version:
Keywords: Cc:

Description

How to reproduce

While doing a POST operation on /wiki/Help/Menu/ImageryContextMenu, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'fa6805a86bf6ed669a26b765',
 'action': u'edit',
 'comment': u'update',
 'from_editor': u'1',
 'page': u'Help/Menu/ImageryContextMenu',
 'save': u'Submit changes',
 'scroll_bar_pos': u'0',
 'sfp_email': u'',
 'sfph_mail': u'',
 'sidebyside': u'on',
 'text': u'[[TranslatedPages(outdated=This page is incomplete. The description for "Offset" and all map window options is missing)]]\r\n\r\n= Context Menu > Imagery Layer =\r\n\r\nLayer for background images.\r\n\r\nImagery Layers have this context menu in the layer list:\r\n\r\n||[[Image(source:trunk/images/dialogs/showhide.png)]]|| [wiki:Dialog/LayerList#ShowHideLayer Show/Hide] ||\r\n||[[Image(source:trunk/images/dialogs/delete.png)]]|| [wiki:Dialog/LayerList#DeleteLayer Delete] ||\r\n||[[Image(source:trunk/images/mapmode/adjustimg.png)]]|| [wiki:Action/ImageryOffset Offset] ||\r\n||||||\r\n||[[Image(source:trunk/images/dialogs/edit.png)]]|| [wiki:Action/RenameLayer Rename Layer] ||\r\n||||||\r\n||[[Image(source:trunk/images/info.png)]]|| [wiki:Action/LayerInfo Info] ||\r\n\r\nand this one in the map window:\r\n\r\n|| || Auto Zoom ||\r\n|| || Auto load tiles ||\r\n|| || Show Errors ||\r\n|| || Load Tile ||\r\n|| || Show Tile Info ||\r\n|| || Load All Tiles ||\r\n|| || Load All Error Tiles ||\r\n|| || Increase zoom ||\r\n|| || Decrease zoom ||\r\n|| || Snap to tile size ||\r\n|| || Flush Tile Cache ||\r\n\r\n== see also ==\r\n* [[Image(source:trunk/images/imagery_menu.png,20)]] [wiki:Menu/Imagery Imagery]\r\n\r\n----\r\nBack to [wiki:Dialog/LayerList Layer List Dialog][[Br]]\r\nBack to [wiki:/Help Main Help]',
 'version': u'4'}

User agent: Mozilla/5.0 (X11; Linux i686; rv:10.0.11) Gecko/20100101 Firefox/10.0.11 Iceweasel/10.0.11

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/wiki/web_ui.py", line 148, in process_request
    return self._do_save(req, versioned_page)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/wiki/web_ui.py", line 339, in _do_save
    req.remote_addr)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/wiki/model.py", line 142, in save
    self.readonly))
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/db/util.py", line 121, in execute
    cursor.execute(query, params)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/db/sqlite_backend.py", line 78, in execute
    result = PyFormatCursor.execute(self, *args)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/db/sqlite_backend.py", line 56, in execute
    args or [])
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/db/sqlite_backend.py", line 48, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: database is locked

P.S.: Please adjust auto-component setting from "Core" to "Trac". Thanks

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by skyper

Was not nice as I was editing in the wiki with the two-side editor and all my work is lost, as "back" brings me back to the version before my edits. Luckily it was not much work.

comment:2 Changed 7 years ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8038.
Install "Lazarus" plugin for such cases. It allows to restore user input.

comment:3 in reply to:  2 ; Changed 7 years ago by skyper

Replying to stoecker:

Closed as duplicate of #8038.
Install "Lazarus" plugin for such cases. It allows to restore user input.

Or do not allow scripts and manually trigger the preview first. Lazy myself did allow osm.de in script blocker

comment:4 in reply to:  3 ; Changed 7 years ago by stoecker

Replying to skyper:

Or do not allow scripts and manually trigger the preview first. Lazy myself did allow osm.de in script blocker

I fear that will not help. If you get a server error the input will be lost. Lazarus saved me already a LOT of work in different wikis or support forms :-)

comment:5 in reply to:  4 Changed 7 years ago by skyper

Replying to stoecker:

Replying to skyper:

Or do not allow scripts and manually trigger the preview first. Lazy myself did allow osm.de in script blocker

I fear that will not help. If you get a server error the input will be lost. Lazarus saved me already a LOT of work in different wikis or support forms :-)

I did never get a "data based lock error" on previews. Is this possible ? Usually the page just does not open. Opening the same page in several tabs you can even notice that the locks are often short but the request is not renewed. E.g. In the first tab the page does not open for minuites or never but in other tabs it opens right away.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain stoecker.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.